Read the docs
TI-2023-16908 Aliases CVE-2023-34042GHSA-9gp8-6cg8-7h34

Incorrect permission assignment in Spring Security

Priority LOW 24CWE-732Published · Updated

Key facts

Attack vector
Local
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · High · None
Fix status
Partial Red Hat: 10 without a fix

Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat.

Summary

The spring-security.xsd file inside the spring-security-config jar is world writable which means that if it were extracted it could be written by anyone with access to the file system. While there are no known exploits, this is an example of “CWE-732: Incorrect Permission Assignment for Critical Resource” and could result in an exploit. Users should update to the latest version of Spring Security to mitigate any future exploits found around this issue.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00239 15th percentileScored 2026-11-07
Fix Partial org.springframework.security:spring-security-config (Maven): 6.1.4, 6.0.7, 5.8.7 +1Red Hat: 10 without a fix

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
N/ASpring SecuritySpring Security 6.1.x prior to 6.1.4, Spring Security 6.0.x prior to 6.0.7, Spring Security 5.8.x prior to 5.8.7, Spring Security 5.7.x prior to 5.7.11—No fix listedCNA
—org.springframework.security:spring-security-config (Maven)6.1.1 to before 6.1.46.1.4Patch availableGHSA-9gp8-6cg8-7h34
—org.springframework.security:spring-security-config (Maven)6.0.4 to before 6.0.76.0.7Patch availableGHSA-9gp8-6cg8-7h34
—org.springframework.security:spring-security-config (Maven)5.8.4 to before 5.8.75.8.7Patch availableGHSA-9gp8-6cg8-7h34
—org.springframework.security:spring-security-config (Maven)5.7.9 to before 5.7.115.7.11Patch availableGHSA-9gp8-6cg8-7h34
  • Spring Security VendorN/A Affected Spring Security 6.1.x prior to 6.1.4, Spring Security 6.0.x prior to 6.0.7, Spring Security 5.8.x prior to 5.8.7, Spring Security 5.7.x prior to 5.7.11 Fixed in — No fix listed CNA
  • org.springframework.security:spring-security-config (Maven) Vendor— Affected 6.1.1 to before 6.1.4 Fixed in 6.1.4 Patch available GHSA-9gp8-6cg8-7h34
  • org.springframework.security:spring-security-config (Maven) Vendor— Affected 6.0.4 to before 6.0.7 Fixed in 6.0.7 Patch available GHSA-9gp8-6cg8-7h34
  • org.springframework.security:spring-security-config (Maven) Vendor— Affected 5.8.4 to before 5.8.7 Fixed in 5.8.7 Patch available GHSA-9gp8-6cg8-7h34
  • org.springframework.security:spring-security-config (Maven) Vendor— Affected 5.7.9 to before 5.7.11 Fixed in 5.7.11 Patch available GHSA-9gp8-6cg8-7h34

CPE configurations NVD · 3

CPEVersionsRoleVendor
cpe:2.3:a:vmware:spring_security:*:*:*:*:*:*:*:*5.8.4 to before 5.8.7; 6.0.4 to before 6.0.7; 6.1.1 to before 6.1.4VulnerableVMware
cpe:2.3:a:vmware:spring_security:5.7.9:*:*:*:*:*:*:*5.7.9VulnerableVMware
cpe:2.3:a:vmware:spring_security:5.7.10:*:*:*:*:*:*:*5.7.10VulnerableVMware
  • cpe:2.3:a:vmware:spring_security:*:*:*:*:*:*:*:* Versions 5.8.4 to before 5.8.7; 6.0.4 to before 6.0.7; 6.1.1 to before 6.1.4 Vulnerable ·VMware
  • cpe:2.3:a:vmware:spring_security:5.7.9:*:*:*:*:*:*:* Versions 5.7.9 Vulnerable ·VMware
  • cpe:2.3:a:vmware:spring_security:5.7.10:*:*:*:*:*:*:* Versions 5.7.10 Vulnerable ·VMware

Remediation

  • Fix · GHSA-9gp8-6cg8-7h34 org.springframework.security:spring-security-config (Maven) Fixed in 6.1.4 Advisory →
  • Fix · GHSA-9gp8-6cg8-7h34 org.springframework.security:spring-security-config (Maven) Fixed in 6.0.7 Advisory →
  • Fix · GHSA-9gp8-6cg8-7h34 org.springframework.security:spring-security-config (Maven) Fixed in 5.8.7 Advisory →
  • Fix · GHSA-9gp8-6cg8-7h34 org.springframework.security:spring-security-config (Maven) Fixed in 5.7.11 Advisory →

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Decision Manager 7AffectedNo fix planned: Will not fix
Red Hat Fuse 7AffectedNo fix yet
Red Hat Integration Camel K 1AffectedNo fix planned: Will not fix
Red Hat JBoss Enterprise Application Platform 6AffectedNo fix planned: Out of support scope
Red Hat JBoss Enterprise Application Platform Expansion PackAffectedNo fix planned: Will not fix
Red Hat OpenShift Dev SpacesAffectedNo fix yet
Red Hat Process Automation 7AffectedNo fix planned: Will not fix
Red Hat Single Sign-On 7AffectedNo fix planned: Will not fix
Red Hat build of Apache Camel for Spring Boot 3AffectedNo fix planned: Out of support scope
streams for Apache KafkaAffectedNo fix planned: Will not fix
Not affected: 7 products
  • A-MQ Clients 2
  • Red Hat Build of Keycloak
  • Red Hat Data Grid 8
  • Red Hat JBoss Data Grid 7
  • Red Hat JBoss Enterprise Application Platform 7
  • Red Hat JBoss Enterprise Application Platform 8
  • Red Hat build of Apache Camel for Spring Boot 4

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-34042
  2. 2026-10-03 Alias added: GHSA-9gp8-6cg8-7h34

References

  • TI-2023-16900 Improper access control in Spring Security CVSS 3.1CRITICAL 9.8
  • TI-2022-13611 Authorization bypass in Spring by VMware CVSS 3.1CRITICAL 9.8
  • TI-2022-07154 Incorrect authorization in Spring Security CVSS 3.1CRITICAL 9.8
  • TI-2026-42404 Spring Security embedded UnboundID LDAP server exposes well-known administrative bind DN on all network interfaces CVSS 3.1CRITICAL 9.4
  • TI-2026-18257 Under Some Conditions Spring Security HTTP Headers Are not Written CVSS 3.1CRITICAL 9.1
  • TI-2014-02853 Improper authentication in Pivotal Spring Security CVSS 3.0CRITICAL 9.8
See all 43 →

Sources