Dependency configuration exposed in Shopware
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
Shopware is an open source e-commerce software. Due to an incorrect configuration in the `.htaccess` file, the configuration file of the Javascript could be read in production environments (`themes/package-lock.json`). With this information, the specific Shopware version in a deployment might be determined by an attacker, which could be used for further attacks. Users are advised to update to version 5.7.18. There are no known workarounds for this vulnerability.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| shopware | shopware | before 5.7.18 | 5.7.18 | Patch available | CNA |
| — | shopware/shopware (Packagist) | 5.6.0 to before 5.7.18 | 5.7.18 | Patch available | GHSA-q97c-2mh3-pgw9 |
- shopware Vendorshopware Affected before 5.7.18 Fixed in 5.7.18 Patch available CNA
- shopware/shopware (Packagist) Vendor— Affected 5.6.0 to before 5.7.18 Fixed in 5.7.18 Patch available GHSA-q97c-2mh3-pgw9
Remediation
- Fix · CNA shopware (shopware) Fixed in 5.7.18
- Fix · GHSA-q97c-2mh3-pgw9 shopware/shopware (Packagist) Fixed in 5.7.18 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-34098
- 2026-10-03 Alias added: GHSA-q97c-2mh3-pgw9
References
Patch 2
Advisory 2
More Shopware vulnerabilities
- TI-2023-01895 Improper Control of Generation of Code in Twig Rendered Views in Shopware CVSS 3.1HIGH 8.8
- TI-2025-20623 Shopware prior to version 6.5.8.13 is affected by a SQL injection vulnerability in the… CVSS 3.1MEDIUM 6.8
- TI-2024-28343 Shopware vulnerable to Server Side Template Injection in Twig using Context functions CVSS 3.1HIGH 8.3
- TI-2019-09582 In createInstanceFromNamedArguments in Shopware through 5.6.x, a crafted web request can… CVSS 3.1HIGH 8.8
- TI-2016-02607 The backend/Login/load/ script in Shopware before 5.1.5 allows remote attackers to execute arbitrary code. CVSS 3.0CRITICAL 9.8
- TI-2025-32365 A stored cross-site scripting (XSS) vulnerability exists in the Shopware 6 installation… CVSS 3.1MEDIUM 6.1
Sources
- CVE-2023-34098 · CVE Program
- CVE-2023-34098 · NVD
- FIRST EPSS
- GHSA-q97c-2mh3-pgw9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences