Read the docs
TI-2023-17578 Aliases CVE-2023-35131GHSA-fwfj-8p36-rc64

Moodle: xss risk on groups page

Priority LOW 28CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

Content on the groups page required additional sanitizing to prevent an XSS risk. This flaw affects Moodle versions 4.2, 4.1 to 4.1.3, 4.0 to 4.0.8 and 3.11 to 3.11.14.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00677 52nd percentileScored 2026-11-07
Fix Fixed moodle: 4.2.1, 4.1.4, 4.0.9 +1moodle/moodle (Packagist): 4.2.1, 4.1.4, 4.0.9 +1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
—moodle4.2.0 to before 4.2.1; 4.1.0 to before 4.1.4; 4.0.0 to before 4.0.9; 3.11.0 to before 3.11.154.2.1, 4.1.4, 4.0.9, 3.11.15Patch availableCNA
—moodle/moodle (Packagist)4.2.0 to before 4.2.14.2.1Patch availableGHSA-fwfj-8p36-rc64
—moodle/moodle (Packagist)4.1.0 to before 4.1.44.1.4Patch availableGHSA-fwfj-8p36-rc64
—moodle/moodle (Packagist)4.0.0 to before 4.0.94.0.9Patch availableGHSA-fwfj-8p36-rc64
—moodle/moodle (Packagist)before 3.11.153.11.15Patch availableGHSA-fwfj-8p36-rc64
  • moodle Vendor— Affected 4.2.0 to before 4.2.1; 4.1.0 to before 4.1.4; 4.0.0 to before 4.0.9; 3.11.0 to before 3.11.15 Fixed in 4.2.1, 4.1.4, 4.0.9, 3.11.15 Patch available CNA
  • moodle/moodle (Packagist) Vendor— Affected 4.2.0 to before 4.2.1 Fixed in 4.2.1 Patch available GHSA-fwfj-8p36-rc64
  • moodle/moodle (Packagist) Vendor— Affected 4.1.0 to before 4.1.4 Fixed in 4.1.4 Patch available GHSA-fwfj-8p36-rc64
  • moodle/moodle (Packagist) Vendor— Affected 4.0.0 to before 4.0.9 Fixed in 4.0.9 Patch available GHSA-fwfj-8p36-rc64
  • moodle/moodle (Packagist) Vendor— Affected before 3.11.15 Fixed in 3.11.15 Patch available GHSA-fwfj-8p36-rc64

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:*3.11.0 to before 3.11.15; 4.0.0 to before 4.0.9; 4.1.0 to before 4.1.4VulnerableMoodle
cpe:2.3:a:moodle:moodle:4.2.0:*:*:*:*:*:*:*4.2.0VulnerableMoodle
  • cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions 3.11.0 to before 3.11.15; 4.0.0 to before 4.0.9; 4.1.0 to before 4.1.4 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:4.2.0:*:*:*:*:*:*:* Versions 4.2.0 Vulnerable ·Moodle

Remediation

  • Fix · CNA moodle Fixed in 4.2.1, 4.1.4, 4.0.9, 3.11.15
  • Fix · GHSA-fwfj-8p36-rc64 moodle/moodle (Packagist) Fixed in 4.2.1 Advisory →
  • Fix · GHSA-fwfj-8p36-rc64 moodle/moodle (Packagist) Fixed in 4.1.4 Advisory →
  • Fix · GHSA-fwfj-8p36-rc64 moodle/moodle (Packagist) Fixed in 4.0.9 Advisory →
  • Fix · GHSA-fwfj-8p36-rc64 moodle/moodle (Packagist) Fixed in 3.11.15 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-35131
  2. 2026-10-03 Alias added: GHSA-fwfj-8p36-rc64

References

  • TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
  • TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
  • TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
  • TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
  • TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
  • TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
See all 636 →

Sources