Read the docs
TI-2023-17579 Aliases CVE-2023-35132GHSA-49mv-vfcp-8gg9

Moodle: minor sql injection risk on mnet sso access control page

Priority LOW 29CWE-89Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
SQL injection
Confidentiality · integrity · availability
Low · Low · Low
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-89.

Summary

A limited SQL injection risk was identified on the Mnet SSO access control page. This flaw affects Moodle versions 4.2, 4.1 to 4.1.3, 4.0 to 4.0.8, 3.11 to 3.11.14, 3.9 to 3.9.21 and earlier unsupported versions.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00802 56th percentileScored 2026-11-07
Fix Fixed moodle: 4.2.1, 4.1.4, 4.0.9 +2moodle/moodle (Packagist): 4.2.1, 4.1.4, 4.0.9 +2

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
—moodle4.2.0 to before 4.2.1; 4.1.0 to before 4.1.4; 4.0.0 to before 4.0.9; 3.11.0 to before 3.11.15; before 3.9.224.2.1, 4.1.4, 4.0.9, 3.11.15, 3.9.22Patch availableCNA
—moodle/moodle (Packagist)4.2.0 to before 4.2.14.2.1Patch availableGHSA-49mv-vfcp-8gg9
—moodle/moodle (Packagist)4.1.0 to before 4.1.44.1.4Patch availableGHSA-49mv-vfcp-8gg9
—moodle/moodle (Packagist)4.0.0 to before 4.0.94.0.9Patch availableGHSA-49mv-vfcp-8gg9
—moodle/moodle (Packagist)3.10.0 to before 3.11.153.11.15Patch availableGHSA-49mv-vfcp-8gg9
—moodle/moodle (Packagist)before 3.9.223.9.22Patch availableGHSA-49mv-vfcp-8gg9
  • moodle Vendor— Affected 4.2.0 to before 4.2.1; 4.1.0 to before 4.1.4; 4.0.0 to before 4.0.9; 3.11.0 to before 3.11.15; before 3.9.22 Fixed in 4.2.1, 4.1.4, 4.0.9, 3.11.15, 3.9.22 Patch available CNA
  • moodle/moodle (Packagist) Vendor— Affected 4.2.0 to before 4.2.1 Fixed in 4.2.1 Patch available GHSA-49mv-vfcp-8gg9
  • moodle/moodle (Packagist) Vendor— Affected 4.1.0 to before 4.1.4 Fixed in 4.1.4 Patch available GHSA-49mv-vfcp-8gg9
  • moodle/moodle (Packagist) Vendor— Affected 4.0.0 to before 4.0.9 Fixed in 4.0.9 Patch available GHSA-49mv-vfcp-8gg9
  • moodle/moodle (Packagist) Vendor— Affected 3.10.0 to before 3.11.15 Fixed in 3.11.15 Patch available GHSA-49mv-vfcp-8gg9
  • moodle/moodle (Packagist) Vendor— Affected before 3.9.22 Fixed in 3.9.22 Patch available GHSA-49mv-vfcp-8gg9

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:*before 3.9.22; 3.11.0 to before 3.11.15; 4.0.0 to before 4.0.9; 4.1.0 to before 4.1.4VulnerableMoodle
cpe:2.3:a:moodle:moodle:4.2.0:*:*:*:*:*:*:*4.2.0VulnerableMoodle
  • cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions before 3.9.22; 3.11.0 to before 3.11.15; 4.0.0 to before 4.0.9; 4.1.0 to before 4.1.4 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:4.2.0:*:*:*:*:*:*:* Versions 4.2.0 Vulnerable ·Moodle

Remediation

  • Fix · CNA moodle Fixed in 4.2.1, 4.1.4, 4.0.9, 3.11.15, 3.9.22
  • Fix · GHSA-49mv-vfcp-8gg9 moodle/moodle (Packagist) Fixed in 4.2.1 Advisory →
  • Fix · GHSA-49mv-vfcp-8gg9 moodle/moodle (Packagist) Fixed in 4.1.4 Advisory →
  • Fix · GHSA-49mv-vfcp-8gg9 moodle/moodle (Packagist) Fixed in 4.0.9 Advisory →
  • Fix · GHSA-49mv-vfcp-8gg9 moodle/moodle (Packagist) Fixed in 3.11.15 Advisory →
  • Fix · GHSA-49mv-vfcp-8gg9 moodle/moodle (Packagist) Fixed in 3.9.22 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-35132
  2. 2026-10-03 Alias added: GHSA-49mv-vfcp-8gg9

References

  • TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
  • TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
  • TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
  • TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
  • TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
  • TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
See all 636 →

Sources