Read the docs
TI-2023-19079 Aliases CVE-2023-37471GHSA-4mh8-9wq6-rjxg

User impersonation using SAMLv1.x SSO in Open Access Management

Priority MEDIUM 51CWE-287Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-287.

Summary

Open Access Management (OpenAM) is an access management solution that includes Authentication, SSO, Authorization, Federation, Entitlements and Web Services Security. OpenAM up to version 14.7.2 does not properly validate the signature of SAML responses received as part of the SAMLv1.x Single Sign-On process. Attackers can use this fact to impersonate any OpenAM user, including the administrator, by sending a specially crafted SAML response to the SAMLPOSTProfileServlet servlet. This problem has been patched in OpenAM 14.7.3-SNAPSHOT and later. User unable to upgrade should comment servlet `SAMLPOSTProfileServlet` from their pom file. See the linked GHSA for details.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0126 69th percentileScored 2026-11-07
Fix Fixed OpenAM (OpenIdentityPlatform): 14.7.3org.openidentityplatform.openam:openam-federation-library (Maven): 14.7.3

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
OpenIdentityPlatformOpenAMbefore 14.7.314.7.3Patch availableCNA
—org.openidentityplatform.openam:openam-federation-library (Maven)before 14.7.314.7.3Patch availableGHSA-4mh8-9wq6-rjxg
  • OpenAM VendorOpenIdentityPlatform Affected before 14.7.3 Fixed in 14.7.3 Patch available CNA
  • org.openidentityplatform.openam:openam-federation-library (Maven) Vendor— Affected before 14.7.3 Fixed in 14.7.3 Patch available GHSA-4mh8-9wq6-rjxg

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:openidentityplatform:openam:*:*:*:*:*:*:*:*before 14.7.3VulnerableOpenIdentityPlatform
  • cpe:2.3:a:openidentityplatform:openam:*:*:*:*:*:*:*:* Versions before 14.7.3 Vulnerable ·OpenIdentityPlatform

Remediation

  • Fix · CNA OpenAM (OpenIdentityPlatform) Fixed in 14.7.3
  • Fix · GHSA-4mh8-9wq6-rjxg org.openidentityplatform.openam:openam-federation-library (Maven) Fixed in 14.7.3 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-37471
  2. 2026-10-03 Alias added: GHSA-4mh8-9wq6-rjxg

References

  • TI-2026-25836 Pre-Authentication Remote Code Execution via `jato.clientSession` Deserialization in OpenAM CVSS 4.0CRITICAL 9.3
  • TI-2022-15210 The NT auth module in OpenAM before 14.6.6 allows a "replace Samba username attack." CVSS 3.1MEDIUM 5.3

Sources