Pre-Authentication Remote Code Execution via `jato.clientSession` Deserialization in OpenAM
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-502.
Summary
Open Access Management (OpenAM) is an access management solution. Prior to 16.0.6, OpenIdentityPlatform OpenAM is vulnerable to pre-authentication Remote Code Execution (RCE) via unsafe Java deserialization of the jato.clientSession HTTP parameter. This bypasses the WhitelistObjectInputStream mitigation that was applied to the jato.pageSession parameter after CVE-2021-35464. An unauthenticated attacker can achieve arbitrary command execution on the server by sending a crafted serialized Java object as the jato.clientSession GET/POST parameter to any JATO ViewBean endpoint whose JSP contains <jato:form> tags (e.g., the Password Reset pages). This vulnerability is fixed in 16.0.6.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| OpenIdentityPlatform | OpenAM | before 16.0.6 | 16.0.6 | Patch available | CNA |
| — | org.openidentityplatform.openam:openam (Maven) | before 16.0.6 | 16.0.6 | Patch available | GHSA-2cqq-rpvq-g5qj |
- OpenAM VendorOpenIdentityPlatform Affected before 16.0.6 Fixed in 16.0.6 Patch available CNA
- org.openidentityplatform.openam:openam (Maven) Vendor— Affected before 16.0.6 Fixed in 16.0.6 Patch available GHSA-2cqq-rpvq-g5qj
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:openidentityplatform:openam:*:*:*:*:*:*:*:* | before 16.0.6 | Vulnerable | OpenIdentityPlatform |
- cpe:2.3:a:openidentityplatform:openam:*:*:*:*:*:*:*:* Versions before 16.0.6 Vulnerable ·OpenIdentityPlatform
Remediation
- Fix · CNA OpenAM (OpenIdentityPlatform) Fixed in 16.0.6
- Fix · GHSA-2cqq-rpvq-g5qj org.openidentityplatform.openam:openam (Maven) Fixed in 16.0.6 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-33439
- 2026-10-03 Alias added: GHSA-2cqq-rpvq-g5qj
- 2026-10-25 EPSS moved to the 95th–99th percentile
References
More OpenIdentityPlatform Openam vulnerabilities
- TI-2023-19079 User impersonation using SAMLv1.x SSO in Open Access Management CVSS 3.1CRITICAL 9.8
- TI-2022-15210 The NT auth module in OpenAM before 14.6.6 allows a "replace Samba username attack." CVSS 3.1MEDIUM 5.3
Sources
- CVE-2026-33439 · CVE Program
- CVE-2026-33439 · NVD
- FIRST EPSS
- GHSA-2cqq-rpvq-g5qj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences