Read the docs
TI-2023-19928 Aliases CVE-2023-38552GHSA-x39v-frq9-5hh8

Insufficient verification of data authenticity in NodeJS Node

Priority MEDIUM 41CWE-345Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
None · High · None
Fix status
Partial Red Hat: 2 fixed, 3 without a fix

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat. Impact type from CWE-345.

Summary

When the Node.js policy feature checks the integrity of a resource against a trusted manifest, the application can intercept the operation and return a forged checksum to the node's policy implementation, thus effectively disabling the integrity check. Impacts: This vulnerability affects all users using the experimental policy mechanism in all active release lines: 18.x and, 20.x. Please note that at the time this CVE was issued, the policy mechanism is an experimental feature of Node.js.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01236 69th percentileScored 2026-11-07
Fix Partial Node (NodeJS): 18.18.2, 20.8.1Red Hat: 3 advisoriesRed Hat: 2 fixed, 3 without a fix

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
NodeJSNode4.0 and later; 5.0 and later; 6.0 and later; 7.0 and later; 8.0 and later; 9.0 and later; 10.0 and later; 11.0 and later; 12.0 and later; 13.0 and later; 14.0 and later; 15.0 and later; 16.0 and later; 17.0 and later; 18.0 to before 18.18.2; 19.0 and later; 20.0 to before 20.8.118.18.2, 20.8.1Patch availableCNA
  • Node VendorNodeJS Affected 4.0 and later; 5.0 and later; 6.0 and later; 7.0 and later; 8.0 and later; 9.0 and later; 10.0 and later; 11.0 and later; 12.0 and later; 13.0 and later; 14.0 and later; 15.0 and later; 16.0 and later; 17.0 and later; 18.0 to before 18.18.2; 19.0 and later; 20.0 to before 20.8.1 Fixed in 18.18.2, 20.8.1 Patch available CNA

CPE configurations NVD · 4

CPEVersionsRoleVendor
cpe:2.3:a:nodejs:node.js:*:*:*:*:*:*:*:*18.0.0 – 18.18.1; 20.1.0 – 20.8.0VulnerableNodeJS
cpe:2.3:o:fedoraproject:fedora:37:*:*:*:*:*:*:*37VulnerableFedoraproject
cpe:2.3:o:fedoraproject:fedora:38:*:*:*:*:*:*:*38VulnerableFedoraproject
cpe:2.3:o:fedoraproject:fedora:39:*:*:*:*:*:*:*39VulnerableFedoraproject
  • cpe:2.3:a:nodejs:node.js:*:*:*:*:*:*:*:* Versions 18.0.0 – 18.18.1; 20.1.0 – 20.8.0 Vulnerable ·NodeJS
  • cpe:2.3:o:fedoraproject:fedora:37:*:*:*:*:*:*:* Versions 37 Vulnerable ·Fedoraproject
  • cpe:2.3:o:fedoraproject:fedora:38:*:*:*:*:*:*:* Versions 38 Vulnerable ·Fedoraproject
  • cpe:2.3:o:fedoraproject:fedora:39:*:*:*:*:*:*:* Versions 39 Vulnerable ·Fedoraproject

Remediation

  • Fix · CNA Node (NodeJS) Fixed in 18.18.2, 20.8.1

Red Hat 3 advisories

  • RHSA-2023:7205 Released 2023-11-14 · Red Hat rating Important
    nodejs:20 security update
    • Red Hat Enterprise Linux AppStream (v. 8) nodejs-1:20.8.1-1.module+el8.9.0+20473+c4e3d824.aarch64::nodejs:20, nodejs-1:20.8.1-1.module+el8.9.0+20473+c4e3d824.ppc64le::nodejs:20, nodejs-1:20.8.1-1.module+el8.9.0+20473+c4e3d824.s390x::nodejs:20 +20
  • RHSA-2023:5869 Released 2023-10-18 · Red Hat rating Important
    nodejs:18 security update
    • Red Hat Enterprise Linux AppStream (v. 8) nodejs-1:18.18.2-1.module+el8.8.0+20407+c11d40bd.aarch64::nodejs:18, nodejs-1:18.18.2-1.module+el8.8.0+20407+c11d40bd.ppc64le::nodejs:18, nodejs-1:18.18.2-1.module+el8.8.0+20407+c11d40bd.s390x::nodejs:18 +20
  • RHSA-2023:5849 Released 2023-10-18 · Red Hat rating Important
    nodejs:18 security update
    • Red Hat Enterprise Linux AppStream (v. 9) nodejs-1:18.18.2-2.module+el9.2.0.z+20408+7cb5fda5.aarch64::nodejs:18, nodejs-1:18.18.2-2.module+el9.2.0.z+20408+7cb5fda5.ppc64le::nodejs:18, nodejs-1:18.18.2-2.module+el9.2.0.z+20408+7cb5fda5.s390x::nodejs:18 +20

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Enterprise Linux 8AffectedNo fix planned: Will not fix
Red Hat Enterprise Linux 9AffectedNo fix yet
Red Hat Software CollectionsAffectedNo fix planned: Will not fix
Red Hat Enterprise Linux AppStream (v. 8)Fixed RHSA-2023:5869, RHSA-2023:7205
Red Hat Enterprise Linux AppStream (v. 9)Fixed RHSA-2023:5849

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-38552
  2. 2026-10-03 Alias added: GHSA-x39v-frq9-5hh8

References

  • TI-2026-79288 Out-of-bounds write in Google Brotli decoder KEVCVSS 4.0CRITICAL 9.2
  • TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
  • TI-2016-01993 The DES and Triple DES ciphers, as used in the TLS, SSH, and IPSec protocols and other… CVSS 3.1HIGH 7.5
  • TI-2024-03325 Command injection vulnerability in programing languages on Microsoft Windows operating system. CVSS 3.1CRITICAL 9.8
  • TI-2022-03472 X.509 Email Address Variable Length Buffer Overflow CVSS 3.1HIGH 7.5
  • TI-2022-03315 X.509 Email Address 4-byte Buffer Overflow CVSS 3.1HIGH 7.5
See all 186 →

Sources