Read the docs
TI-2023-20925 Aliases CVE-2023-40035GHSA-44wr-rmwq-3phw

Craft CMS vulnerable to Remote Code Execution via validatePath bypass

Priority HIGH 67CWE-74Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.

Summary

Craft is a CMS for creating custom digital experiences on the web and beyond. Bypassing the validatePath function can lead to potential remote code execution. This vulnerability can lead to malicious control of vulnerable systems and data exfiltrations. Although the vulnerability is exploitable only in the authenticated users, configuration with ALLOW_ADMIN_CHANGES=true, there is still a potential security threat (Remote Code Execution). This issue has been patched in version 4.4.15 and version 3.8.15.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.02317 83rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed cms (craftcms): 4.4.15, 3.8.15craftcms/cms (Packagist): 4.4.15, 3.8.15

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
Craft CMScms4.0.0-RC1 to before 4.4.15; 3.0.0 to before 3.8.154.4.15, 3.8.15Patch availableCNA
—craftcms/cms (Packagist)4.0.0-RC1 to before 4.4.154.4.15Patch availableGHSA-44wr-rmwq-3phw
—craftcms/cms (Packagist)3.0.0 to before 3.8.153.8.15Patch availableGHSA-44wr-rmwq-3phw
  • cms VendorCraft CMS Affected 4.0.0-RC1 to before 4.4.15; 3.0.0 to before 3.8.15 Fixed in 4.4.15, 3.8.15 Patch available CNA
  • craftcms/cms (Packagist) Vendor— Affected 4.0.0-RC1 to before 4.4.15 Fixed in 4.4.15 Patch available GHSA-44wr-rmwq-3phw
  • craftcms/cms (Packagist) Vendor— Affected 3.0.0 to before 3.8.15 Fixed in 3.8.15 Patch available GHSA-44wr-rmwq-3phw

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:craftcms:craft_cms:*:*:*:*:*:*:*:*3.0.0 to before 3.8.15; 4.0.0 to before 4.4.15VulnerableCraft CMS
cpe:2.3:a:craftcms:craft_cms:4.0.0:rc1:*:*:*:*:*:*4.0.0 rc1VulnerableCraft CMS
  • cpe:2.3:a:craftcms:craft_cms:*:*:*:*:*:*:*:* Versions 3.0.0 to before 3.8.15; 4.0.0 to before 4.4.15 Vulnerable ·Craft CMS
  • cpe:2.3:a:craftcms:craft_cms:4.0.0:rc1:*:*:*:*:*:* Versions 4.0.0 rc1 Vulnerable ·Craft CMS

Remediation

  • Fix · CNA cms (craftcms) Fixed in 4.4.15, 3.8.15
  • Fix · GHSA-44wr-rmwq-3phw craftcms/cms (Packagist) Fixed in 4.4.15 Advisory →
  • Fix · GHSA-44wr-rmwq-3phw craftcms/cms (Packagist) Fixed in 3.8.15 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-40035
  2. 2026-10-03 Alias added: GHSA-44wr-rmwq-3phw

References

  • TI-2025-23503 Craft CMS Allows Remote Code Execution KEVCVSS 3.1CRITICAL 10.0
  • TI-2024-37138 RCE when PHP `register_argc_argv` config setting is enabled in craftcms/cms KEVCVSS 4.0CRITICAL 9.3
  • TI-2025-16994 Potential RCE with a compromised security key in craft/cms KEVCVSS 3.1HIGH 8.1
  • TI-2025-24595 Craft CMS stores user-provided content in session files KEVCVSS 4.0MEDIUM 6.9
  • TI-2023-22284 Craft CMS Remote Code Execution vulnerability CVSS 3.1CRITICAL 10.0
  • TI-2024-25171 Craft CMS up to v3.7.31 was discovered to contain a SQL injection vulnerability via the GraphQL API endpoint. CVSS 3.1CRITICAL 9.8
See all 96 →

Sources