Read the docs
TI-2023-21066 Aliases CVE-2023-40196GHSA-f4v3-885v-g55x

WordPress ImageRecycle pdf & image compression Plugin <= 3.1.11 is vulnerable to Cross Site Scripting (XSS)

Priority LOW 31CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · Low
Fix status
No fix listed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.

Summary

Unauth. Reflected Cross-Site Scripting (XSS) vulnerability in ImageRecycle ImageRecycle pdf & image compression plugin <= 3.1.11 versions.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00382 32nd percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
imagerecycleImageRecycle pdf & image compressionup to 3.1.11—No fix listedCNA
  • ImageRecycle pdf & image compression Vendorimagerecycle Affected up to 3.1.11 Fixed in — No fix listed CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:imagerecycle:imagerecycle_pdf_\&_image_compression:*:*:*:*:*:wordpress:*:*before 3.1.12Vulnerableimagerecycle
  • cpe:2.3:a:imagerecycle:imagerecycle_pdf_\&_image_compression:*:*:*:*:*:wordpress:*:* Versions before 3.1.12 Vulnerable ·imagerecycle

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-40196
  2. 2026-10-03 Alias added: GHSA-f4v3-885v-g55x

References

  • TI-2024-36355 WordPress ImageRecycle pdf & image compression plugin <= 3.1.16 - Reflected Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
  • TI-2023-14330 WordPress ImageRecycle pdf & image compression Plugin <= 3.1.10 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
  • TI-2024-06148 ImageRecycle pdf & image compression <= 3.1.14 - Missing Authorization in Several AJAX Actions CVSS 3.1MEDIUM 5.0
  • TI-2024-07528 ImageRecycle pdf & image compression <= 3.1.14 - Cross-Site Request in Several AJAX Actions CVSS 3.1MEDIUM 4.7
  • TI-2024-01243 ImageRecycle pdf & image compression <= 3.1.13 - Cross-Site Request Forgery to Settings Update in enableOptimization CVSS 3.1MEDIUM 4.3
  • TI-2024-01011 ImageRecycle pdf & image compression <= 3.1.13 - Missing Authorization to Plugin Data Removal in reinitialize CVSS 3.1MEDIUM 4.3
See all 14 →

Sources