ImageRecycle pdf & image compression <= 3.1.14 - Missing Authorization in Several AJAX Actions
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-862.
Summary
The ImageRecycle pdf & image compression plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on several AJAX actions in all versions up to, and including, 3.1.14. This makes it possible for authenticated attackers, with Subscriber-level access and above, to perform unauthorized actions, such as updating plugin settings.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| imagerecycle | ImageRecycle pdf & image compression | up to 3.1.14 | — | No fix listed | CNA |
- ImageRecycle pdf & image compression Vendorimagerecycle Affected up to 3.1.14 Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:imagerecycle:imagerecycle_pdf_\&_image_compression:*:*:*:*:*:wordpress:*:* | before 3.1.15 | Vulnerable | imagerecycle |
- cpe:2.3:a:imagerecycle:imagerecycle_pdf_\&_image_compression:*:*:*:*:*:wordpress:*:* Versions before 3.1.15 Vulnerable ·imagerecycle
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-6631
- 2026-10-03 Alias added: GHSA-2prr-7h77-fv63
References
More Imagerecycle Pdf & Image Compression vulnerabilities
- TI-2024-36355 WordPress ImageRecycle pdf & image compression plugin <= 3.1.16 - Reflected Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
- TI-2023-21066 WordPress ImageRecycle pdf & image compression Plugin <= 3.1.11 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
- TI-2023-14330 WordPress ImageRecycle pdf & image compression Plugin <= 3.1.10 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
- TI-2024-07528 ImageRecycle pdf & image compression <= 3.1.14 - Cross-Site Request in Several AJAX Actions CVSS 3.1MEDIUM 4.7
- TI-2024-01243 ImageRecycle pdf & image compression <= 3.1.13 - Cross-Site Request Forgery to Settings Update in enableOptimization CVSS 3.1MEDIUM 4.3
- TI-2024-01011 ImageRecycle pdf & image compression <= 3.1.13 - Missing Authorization to Plugin Data Removal in reinitialize CVSS 3.1MEDIUM 4.3
Sources
- CVE-2024-6631 · CVE Program
- CVE-2024-6631 · NVD
- FIRST EPSS
- GHSA-2prr-7h77-fv63 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences