WordPress ImageRecycle pdf & image compression plugin <= 3.1.16 - Reflected Cross Site Scripting (XSS) vulnerability
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in ImageRecycle ImageRecycle pdf & image compression imagerecycle-pdf-image-compression allows Reflected XSS.This issue affects ImageRecycle pdf & image compression: from n/a through <= 3.1.16.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| imagerecycle | ImageRecycle pdf & image compression | up to 3.1.16 | — | No fix listed | CNA |
- ImageRecycle pdf & image compression Vendorimagerecycle Affected up to 3.1.16 Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:imagerecycle:imagerecycle_pdf_\&_image_compression:*:*:*:*:*:wordpress:*:* | up to 3.1.16 | Vulnerable | imagerecycle |
- cpe:2.3:a:imagerecycle:imagerecycle_pdf_\&_image_compression:*:*:*:*:*:wordpress:*:* Versions up to 3.1.16 Vulnerable ·imagerecycle
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-54266
- 2026-10-03 Alias added: GHSA-23hv-h2r7-ggj5
More Imagerecycle Pdf & Image Compression vulnerabilities
- TI-2023-21066 WordPress ImageRecycle pdf & image compression Plugin <= 3.1.11 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
- TI-2023-14330 WordPress ImageRecycle pdf & image compression Plugin <= 3.1.10 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
- TI-2024-06148 ImageRecycle pdf & image compression <= 3.1.14 - Missing Authorization in Several AJAX Actions CVSS 3.1MEDIUM 5.0
- TI-2024-07528 ImageRecycle pdf & image compression <= 3.1.14 - Cross-Site Request in Several AJAX Actions CVSS 3.1MEDIUM 4.7
- TI-2024-01243 ImageRecycle pdf & image compression <= 3.1.13 - Cross-Site Request Forgery to Settings Update in enableOptimization CVSS 3.1MEDIUM 4.3
- TI-2024-01011 ImageRecycle pdf & image compression <= 3.1.13 - Missing Authorization to Plugin Data Removal in reinitialize CVSS 3.1MEDIUM 4.3
Sources
- CVE-2024-54266 · CVE Program
- CVE-2024-54266 · NVD
- FIRST EPSS
- GHSA-23hv-h2r7-ggj5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences