Next.js before 13.4.20-canary.13 lacks a cache-control header and thus empty prefetch…
Priority HIGH 72Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
Next.js before 13.4.20-canary.13 lacks a cache-control header and thus empty prefetch responses may sometimes be cached by a CDN, causing a denial of service to all users requesting the same URL via that CDN.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.01608 76th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed next (npm): 13.4.20-canary.13
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | next (npm) | 0.9.9 to before 13.4.20-canary.13 | 13.4.20-canary.13 | Patch available | GHSA-c59h-r6p8-q9wc |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- next (npm) Vendor— Affected 0.9.9 to before 13.4.20-canary.13 Fixed in 13.4.20-canary.13 Patch available GHSA-c59h-r6p8-q9wc
CPE configurations NVD · 14
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:vercel:next.js:*:*:*:*:*:node.js:*:* | before 13.4.20 | Vulnerable | vercel |
| cpe:2.3:a:vercel:next.js:13.4.20:canary0:*:*:*:node.js:*:* | 13.4.20 canary0 | Vulnerable | vercel |
| cpe:2.3:a:vercel:next.js:13.4.20:canary1:*:*:*:node.js:*:* | 13.4.20 canary1 | Vulnerable | vercel |
| cpe:2.3:a:vercel:next.js:13.4.20:canary10:*:*:*:node.js:*:* | 13.4.20 canary10 | Vulnerable | vercel |
| cpe:2.3:a:vercel:next.js:13.4.20:canary11:*:*:*:node.js:*:* | 13.4.20 canary11 | Vulnerable | vercel |
| cpe:2.3:a:vercel:next.js:13.4.20:canary12:*:*:*:node.js:*:* | 13.4.20 canary12 | Vulnerable | vercel |
| cpe:2.3:a:vercel:next.js:13.4.20:canary2:*:*:*:node.js:*:* | 13.4.20 canary2 | Vulnerable | vercel |
| cpe:2.3:a:vercel:next.js:13.4.20:canary3:*:*:*:node.js:*:* | 13.4.20 canary3 | Vulnerable | vercel |
| cpe:2.3:a:vercel:next.js:13.4.20:canary4:*:*:*:node.js:*:* | 13.4.20 canary4 | Vulnerable | vercel |
| cpe:2.3:a:vercel:next.js:13.4.20:canary5:*:*:*:node.js:*:* | 13.4.20 canary5 | Vulnerable | vercel |
- cpe:2.3:a:vercel:next.js:*:*:*:*:*:node.js:*:* Versions before 13.4.20 Vulnerable ·vercel
- cpe:2.3:a:vercel:next.js:13.4.20:canary0:*:*:*:node.js:*:* Versions 13.4.20 canary0 Vulnerable ·vercel
- cpe:2.3:a:vercel:next.js:13.4.20:canary1:*:*:*:node.js:*:* Versions 13.4.20 canary1 Vulnerable ·vercel
- cpe:2.3:a:vercel:next.js:13.4.20:canary10:*:*:*:node.js:*:* Versions 13.4.20 canary10 Vulnerable ·vercel
- cpe:2.3:a:vercel:next.js:13.4.20:canary11:*:*:*:node.js:*:* Versions 13.4.20 canary11 Vulnerable ·vercel
- cpe:2.3:a:vercel:next.js:13.4.20:canary12:*:*:*:node.js:*:* Versions 13.4.20 canary12 Vulnerable ·vercel
- cpe:2.3:a:vercel:next.js:13.4.20:canary2:*:*:*:node.js:*:* Versions 13.4.20 canary2 Vulnerable ·vercel
- cpe:2.3:a:vercel:next.js:13.4.20:canary3:*:*:*:node.js:*:* Versions 13.4.20 canary3 Vulnerable ·vercel
- cpe:2.3:a:vercel:next.js:13.4.20:canary4:*:*:*:node.js:*:* Versions 13.4.20 canary4 Vulnerable ·vercel
- cpe:2.3:a:vercel:next.js:13.4.20:canary5:*:*:*:node.js:*:* Versions 13.4.20 canary5 Vulnerable ·vercel
Show 4 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:vercel:next.js:13.4.20:canary6:*:*:*:node.js:*:* | 13.4.20 canary6 | Vulnerable | vercel |
| cpe:2.3:a:vercel:next.js:13.4.20:canary7:*:*:*:node.js:*:* | 13.4.20 canary7 | Vulnerable | vercel |
| cpe:2.3:a:vercel:next.js:13.4.20:canary8:*:*:*:node.js:*:* | 13.4.20 canary8 | Vulnerable | vercel |
| cpe:2.3:a:vercel:next.js:13.4.20:canary9:*:*:*:node.js:*:* | 13.4.20 canary9 | Vulnerable | vercel |
- cpe:2.3:a:vercel:next.js:13.4.20:canary6:*:*:*:node.js:*:* Versions 13.4.20 canary6 Vulnerable ·vercel
- cpe:2.3:a:vercel:next.js:13.4.20:canary7:*:*:*:node.js:*:* Versions 13.4.20 canary7 Vulnerable ·vercel
- cpe:2.3:a:vercel:next.js:13.4.20:canary8:*:*:*:node.js:*:* Versions 13.4.20 canary8 Vulnerable ·vercel
- cpe:2.3:a:vercel:next.js:13.4.20:canary9:*:*:*:node.js:*:* Versions 13.4.20 canary9 Vulnerable ·vercel
Remediation
- Fix · GHSA-c59h-r6p8-q9wc next (npm) Fixed in 13.4.20-canary.13 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-46298
- 2026-10-03 Alias added: GHSA-c59h-r6p8-q9wc
References
More vercel Next.js vulnerabilities
- TI-2025-34861 Deserialization of untrusted data in Meta react-server-dom-webpack KEVCVSS 3.1CRITICAL 10.0
- TI-2025-21309 Authorization Bypass in Next.js Middleware CVSS 3.1CRITICAL 9.1
- TI-2025-34863 Deserialization of untrusted data in Meta react-server-dom-webpack CVSS 3.1HIGH 7.5
- TI-2024-31371 Cache Poisoning in next.js CVSS 3.1HIGH 7.5
- TI-2026-32490 Next.js: Server-side request forgery in applications using WebSocket upgrades CVSS 3.1HIGH 8.6
- TI-2025-34862 Deserialization of untrusted data in Meta react-server-dom-webpack CVSS 3.1MEDIUM 5.3
Sources
- CVE-2023-46298 · CVE Program
- CVE-2023-46298 · NVD
- FIRST EPSS
- GHSA-c59h-r6p8-q9wc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences