Authorization Bypass in Next.js Middleware
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-285.
Summary
Next.js is a React framework for building full-stack web applications. Starting in version 1.11.4 and prior to versions 12.3.5, 13.5.9, 14.2.25, and 15.2.3, it is possible to bypass authorization checks within a Next.js application, if the authorization check occurs in middleware. If patching to a safe version is infeasible, it is recommend that you prevent external user requests which contain the x-middleware-subrequest header from reaching your Next.js application. This vulnerability is fixed in 12.3.5, 13.5.9, 14.2.25, and 15.2.3.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| vercel | next.js | 11.1.4 to before 12.3.5; 14.0.0 to before 14.2.25; 15.0.0 to before 15.2.3; 13.0.0 to before 13.5.9 | 12.3.5, 14.2.25, 15.2.3, 13.5.9 | Patch available | CNA |
| — | next (npm) | 13.0.0 to before 13.5.9 | 13.5.9 | Patch available | GHSA-f82v-jwr5-mffw |
| — | next (npm) | 14.0.0 to before 14.2.25 | 14.2.25 | Patch available | GHSA-f82v-jwr5-mffw |
| — | next (npm) | 15.0.0 to before 15.2.3 | 15.2.3 | Patch available | GHSA-f82v-jwr5-mffw |
| — | next (npm) | 12.0.0 to before 12.3.5 | 12.3.5 | Patch available | GHSA-f82v-jwr5-mffw |
- next.js Vendorvercel Affected 11.1.4 to before 12.3.5; 14.0.0 to before 14.2.25; 15.0.0 to before 15.2.3; 13.0.0 to before 13.5.9 Fixed in 12.3.5, 14.2.25, 15.2.3, 13.5.9 Patch available CNA
- next (npm) Vendor— Affected 13.0.0 to before 13.5.9 Fixed in 13.5.9 Patch available GHSA-f82v-jwr5-mffw
- next (npm) Vendor— Affected 14.0.0 to before 14.2.25 Fixed in 14.2.25 Patch available GHSA-f82v-jwr5-mffw
- next (npm) Vendor— Affected 15.0.0 to before 15.2.3 Fixed in 15.2.3 Patch available GHSA-f82v-jwr5-mffw
- next (npm) Vendor— Affected 12.0.0 to before 12.3.5 Fixed in 12.3.5 Patch available GHSA-f82v-jwr5-mffw
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:vercel:next.js:*:*:*:*:*:node.js:*:* | 11.1.4 to before 12.3.5; 13.0.0 to before 13.5.9; 14.0.0 to before 14.2.25; 15.0.0 to before 15.2.3 | Vulnerable | vercel |
- cpe:2.3:a:vercel:next.js:*:*:*:*:*:node.js:*:* Versions 11.1.4 to before 12.3.5; 13.0.0 to before 13.5.9; 14.0.0 to before 14.2.25; 15.0.0 to before 15.2.3 Vulnerable ·vercel
Remediation
- Fix · CNA next.js (vercel) Fixed in 12.3.5, 14.2.25, 15.2.3, 13.5.9
- Fix · GHSA-f82v-jwr5-mffw next (npm) Fixed in 13.5.9 Advisory →
- Fix · GHSA-f82v-jwr5-mffw next (npm) Fixed in 14.2.25 Advisory →
- Fix · GHSA-f82v-jwr5-mffw next (npm) Fixed in 15.2.3 Advisory →
- Fix · GHSA-f82v-jwr5-mffw next (npm) Fixed in 12.3.5 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Critical. Red Hat's page for this CVE →
Not affected: 7 products
- Red Hat Enterprise Linux 10
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
- Red Hat Enterprise Linux AI (RHEL AI)
- Red Hat Trusted Artifact Signer
- streams for Apache Kafka 2
Timeline
- 2026-10-02 Threatist record created from CVE-2025-29927
- 2026-10-03 Alias added: GHSA-f82v-jwr5-mffw
References
Patch 2
Advisory 4
Other 6
- https://github.com/vercel/next.js/releases/tag/v12.3.5
- https://github.com/vercel/next.js/releases/tag/v13.5.9
- https://github.com/vercel/next.js
- https://security.netapp.com/advisory/ntap-20250328-0002
- https://vercel.com/changelog/vercel-firewall-proactively-protects-against-vulnerability-with-middleware
- http://www.openwall.com/lists/oss-security/2025/03/23/4
More vercel Next.js vulnerabilities
- TI-2025-34861 Deserialization of untrusted data in Meta react-server-dom-webpack KEVCVSS 3.1CRITICAL 10.0
- TI-2025-34863 Deserialization of untrusted data in Meta react-server-dom-webpack CVSS 3.1HIGH 7.5
- TI-2024-31371 Cache Poisoning in next.js CVSS 3.1HIGH 7.5
- TI-2023-24914 Next.js before 13.4.20-canary.13 lacks a cache-control header and thus empty prefetch… CVSS 3.1HIGH 7.5
- TI-2026-32490 Next.js: Server-side request forgery in applications using WebSocket upgrades CVSS 3.1HIGH 8.6
- TI-2025-34862 Deserialization of untrusted data in Meta react-server-dom-webpack CVSS 3.1MEDIUM 5.3
Sources
- CVE-2025-29927 · CVE Program
- CVE-2025-29927 · NVD
- FIRST EPSS
- GHSA-f82v-jwr5-mffw · GitHub Advisory Database · CC BY 4.0
- CVE-2025-29927 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences