Next.js: Server-side request forgery in applications using WebSocket upgrades
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Partial Red Hat: 4 fixed, 1 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-918 and the CVSS impact.
Summary
Next.js is a React framework for building full-stack web applications. From 13.4.13 to before 15.5.16 and 16.2.5, self-hosted applications using the built-in Node.js server can be vulnerable to server-side request forgery through crafted WebSocket upgrade requests. An attacker can cause the server to proxy requests to arbitrary internal or external destinations, which may expose internal services or cloud metadata endpoints. Vercel-hosted deployments are not affected. This vulnerability is fixed in 15.5.16 and 16.2.5.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| vercel | next.js | 16.0.0 to before 16.2.5; 13.4.13 to before 15.5.16 | 16.2.5, 15.5.16 | Patch available | CNA |
| — | next (npm) | 13.4.13 to before 15.5.16 | 15.5.16 | Patch available | GHSA-c4j6-fc7j-m34r |
| — | next (npm) | 16.0.0 to before 16.2.5 | 16.2.5 | Patch available | GHSA-c4j6-fc7j-m34r |
- next.js Vendorvercel Affected 16.0.0 to before 16.2.5; 13.4.13 to before 15.5.16 Fixed in 16.2.5, 15.5.16 Patch available CNA
- next (npm) Vendor— Affected 13.4.13 to before 15.5.16 Fixed in 15.5.16 Patch available GHSA-c4j6-fc7j-m34r
- next (npm) Vendor— Affected 16.0.0 to before 16.2.5 Fixed in 16.2.5 Patch available GHSA-c4j6-fc7j-m34r
Remediation
- Fix · CNA next.js (vercel) Fixed in 16.2.5, 15.5.16
- Fix · GHSA-c4j6-fc7j-m34r next (npm) Fixed in 15.5.16 Advisory →
- Fix · GHSA-c4j6-fc7j-m34r next (npm) Fixed in 16.2.5 Advisory →
Red Hat 4 advisories
- RHSA-2026:54435 Released 2026-08-12 · Red Hat rating ImportantStreams for Apache Kafka 3.2.1 release and security update
- Streams for Apache Kafka 3.2.1
- RHSA-2026:40974 Released 2026-07-16 · Red Hat rating ImportantRHTAS 1.3.6 - Red Hat Trusted Artifact Signer Release
- Red Hat Trusted Artifact Signer 1.3 registry.redhat.io/rhtas/certificate-transparency-rhel9, registry.redhat.io/rhtas/fulcio-rhel9, registry.redhat.io/rhtas/rekor-backfill-redis-rhel9 +6
- RHSA-2026:37272 Released 2026-07-09 · Red Hat rating ImportantRHTAS 1.4.2 - Red Hat Trusted Artifact Signer Release
- Red Hat Trusted Artifact Signer 1.4 registry.redhat.io/rhtas/certificate-transparency-rhel9, registry.redhat.io/rhtas/fulcio-rhel9, registry.redhat.io/rhtas/rekor-backfill-redis-rhel9 +6
Show 1 more Red Hat advisories
- RHSA-2026:34608 Released 2026-07-02 · Red Hat rating ImportantStreams for Apache Kafka 2.9.4 release and security update
- Streams for Apache Kafka 2.9.4
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux AI (RHEL AI) 3 | Affected | No fix planned: Will not fix |
| Red Hat Trusted Artifact Signer 1.3 | Fixed | RHSA-2026:40974 |
| Red Hat Trusted Artifact Signer 1.4 | Fixed | RHSA-2026:37272 |
| Streams for Apache Kafka 2.9.4 | Fixed | RHSA-2026:34608 |
| Streams for Apache Kafka 3.2.1 | Fixed | RHSA-2026:54435 |
Not affected: 6 products
- Red Hat Enterprise Linux 10
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
- Red Hat Trusted Artifact Signer 1.3
- Red Hat Trusted Artifact Signer 1.4
Timeline
- 2026-10-02 Threatist record created from CVE-2026-44578
- 2026-10-03 Alias added: GHSA-c4j6-fc7j-m34r
- 2026-10-25 EPSS moved to the 95th–99th percentile
- 2026-10-25 Priority changed: MEDIUM → HIGH
References
More vercel Next.js vulnerabilities
- TI-2025-34861 Deserialization of untrusted data in Meta react-server-dom-webpack KEVCVSS 3.1CRITICAL 10.0
- TI-2025-21309 Authorization Bypass in Next.js Middleware CVSS 3.1CRITICAL 9.1
- TI-2025-34863 Deserialization of untrusted data in Meta react-server-dom-webpack CVSS 3.1HIGH 7.5
- TI-2024-31371 Cache Poisoning in next.js CVSS 3.1HIGH 7.5
- TI-2023-24914 Next.js before 13.4.20-canary.13 lacks a cache-control header and thus empty prefetch… CVSS 3.1HIGH 7.5
- TI-2025-34862 Deserialization of untrusted data in Meta react-server-dom-webpack CVSS 3.1MEDIUM 5.3
Sources
- CVE-2026-44578 · CVE Program
- CVE-2026-44578 · NVD
- FIRST EPSS
- GHSA-c4j6-fc7j-m34r · GitHub Advisory Database · CC BY 4.0
- CVE-2026-44578 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences