An insecure default to allow UEFI Shell in EDK2 was left enabled in Ubuntu's EDK2.
Priority HIGH 65CWE-1188Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
An insecure default to allow UEFI Shell in EDK2 was left enabled in Ubuntu's EDK2. This allows an OS-resident attacker to bypass Secure Boot.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00256 17th percentileScored 2026-11-07
Fix Fixed Ubuntu EDK II (Canonical Ltd.): 2023.05-2ubuntu0.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Canonical | Ubuntu EDK II | before 2023.05-2ubuntu0.1 | 2023.05-2ubuntu0.1 | Patch available | CNA |
- Ubuntu EDK II VendorCanonical Affected before 2023.05-2ubuntu0.1 Fixed in 2023.05-2ubuntu0.1 Patch available CNA
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:canonical:lxd:5.0:candidate:*:*:*:*:*:* | 5.0 candidate | Vulnerable | Canonical |
| cpe:2.3:a:canonical:lxd:5.21:candidate:*:*:*:*:*:* | 5.21 candidate | Vulnerable | Canonical |
| cpe:2.3:a:canonical:lxd:5.21:edge:*:*:*:*:*:* | 5.21 edge | Vulnerable | Canonical |
| cpe:2.3:a:tianocore:edk2:*:-:*:*:*:*:*:* | up to 2023.11-8 | Vulnerable | TianoCore |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
- cpe:2.3:a:canonical:lxd:5.0:candidate:*:*:*:*:*:* Versions 5.0 candidate Vulnerable ·Canonical
- cpe:2.3:a:canonical:lxd:5.21:candidate:*:*:*:*:*:* Versions 5.21 candidate Vulnerable ·Canonical
- cpe:2.3:a:canonical:lxd:5.21:edge:*:*:*:*:*:* Versions 5.21 edge Vulnerable ·Canonical
- cpe:2.3:a:tianocore:edk2:*:-:*:*:*:*:*:* Versions up to 2023.11-8 Vulnerable ·TianoCore
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
Remediation
- Fix · CNA Ubuntu EDK II (Canonical Ltd.) Fixed in 2023.05-2ubuntu0.1
Timeline
- 2026-10-02 Threatist record created from CVE-2023-48733
- 2026-10-03 Alias added: GHSA-cjc8-gmgf-qv2g
References
More Canonical Lxd vulnerabilities
- TI-2026-22659 Authenticated RCE via unsanitized compression_algorithm CVSS 4.0CRITICAL 9.4
- TI-2026-47475 Path traversal via unvalidated instance name in backup tarball restore enables root file write / RCE CVSS 3.1CRITICAL 9.9
- TI-2026-45146 Cross-project instance move bypasses all project restrictions allowing host command execution CVSS 3.1CRITICAL 9.9
- TI-2026-45143 Cross-project instance copy bypasses target project restrictions via TOCTOU in config merge CVSS 3.1CRITICAL 9.9
- TI-2026-45142 Project restriction bypass via instance migration config override CVSS 3.1CRITICAL 9.9
- TI-2026-45140 Root RCE via image backup.yaml symlink CVSS 3.1CRITICAL 9.9
Sources
- CVE-2023-48733 · CVE Program
- CVE-2023-48733 · NVD
- FIRST EPSS
- GHSA-cjc8-gmgf-qv2g · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences