Read the docs
TI-2023-27410 Aliases CVE-2023-50168GHSA-2x9x-24qc-mmqv

Pega Platform from 6.x to 8.8.4 is affected by an XXE issue with PDF Generation.

Priority LOW 34CWE-611Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Information disclosure
Confidentiality · integrity · availability
High · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-611 and the CVSS impact.

Summary

Pega Platform from 6.x to 8.8.4 is affected by an XXE issue with PDF Generation.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00392 33rd percentileScored 2026-11-07
Fix Fixed Pega Platform (Pegasystems): 8.8.5

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
PegasystemsPega Platform6.x to before 8.8.58.8.5Patch availableCNA
  • Pega Platform VendorPegasystems Affected 6.x to before 8.8.5 Fixed in 8.8.5 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:pega:pega_platform:*:*:*:*:*:*:*:*before 8.8.5VulnerablePegasystems
  • cpe:2.3:a:pega:pega_platform:*:*:*:*:*:*:*:* Versions before 8.8.5 Vulnerable ·Pegasystems

Remediation

  • Fix · CNA Pega Platform (Pegasystems) Fixed in 8.8.5

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-50168
  2. 2026-10-03 Alias added: GHSA-2x9x-24qc-mmqv

References

  • TI-2023-15393 Pega platform clients who are using versions 6.1 through 7.3.1 may be utilizing default credentials CVSS 3.1CRITICAL 9.8
  • TI-2020-12137 pyActivity in Pega Platform 8.4.0.237 has a security misconfiguration that leads to an… CVSS 3.1CRITICAL 9.8
  • TI-2023-12673 Pega platform clients who are using versions 7.4 through 8.8.x and have upgraded from a… CVSS 3.1CRITICAL 9.8
  • TI-2020-07035 Pega Platform before version 8.2.6 is affected by a Reflected Cross-Site Scripting… CVSS 3.1HIGH 8.8
  • TI-2019-12322 PEGA Platform 8.3.0 is vulnerable to a direct… CVSS 3.1HIGH 8.1
  • TI-2025-01892 Pega Platform versions 8.4.3 to Infinity 24.2.1 are affected by an XSS issue with Mashup CVSS 3.1HIGH 8.1
See all 28 →

Sources