Read the docs
TI-2023-27564 Aliases CVE-2023-50378GHSA-9q6v-rxmw-g3gh

Apache Ambari: Various XSS problems

Priority LOW 30CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

Lack of proper input validation and constraint enforcement in Apache Ambari prior to 2.7.8    Impact : As it will be stored XSS, Could be exploited to perform unauthorized actions, varying from data access to session hijacking and delivering malicious payloads. Users are recommended to upgrade to version 2.7.8 which fixes this issue.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01212 68th percentileScored 2026-11-07
Fix Fixed org.apache.ambari:ambari (Maven): 2.7.8

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ApacheApache Ambari2.7.0 – 2.7.7—No fix listedCNA
—org.apache.ambari:ambari (Maven)before 2.7.82.7.8Patch availableGHSA-9q6v-rxmw-g3gh
  • Apache Ambari VendorApache Affected 2.7.0 – 2.7.7 Fixed in — No fix listed CNA
  • org.apache.ambari:ambari (Maven) Vendor— Affected before 2.7.8 Fixed in 2.7.8 Patch available GHSA-9q6v-rxmw-g3gh

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:apache:ambari:*:*:*:*:*:*:*:*2.7.0 to before 2.7.8VulnerableApache
  • cpe:2.3:a:apache:ambari:*:*:*:*:*:*:*:* Versions 2.7.0 to before 2.7.8 Vulnerable ·Apache

Remediation

  • Fix · GHSA-9q6v-rxmw-g3gh org.apache.ambari:ambari (Maven) Fixed in 2.7.8 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-50378
  2. 2026-10-03 Alias added: GHSA-9q6v-rxmw-g3gh

References

  • TI-2016-05848 Improper access control in Apache Ambari CVSS 3.0CRITICAL 9.8
  • TI-2017-03642 During installation of Ambari 2.4.0 through 2.4.2, Ambari Server artifacts are not created with proper ACLs. CVSS 3.0CRITICAL 9.8
  • TI-2014-02906 In Ambari 1.2.0 through 2.2.2, it may be possible to execute arbitrary system commands on… CVSS 3.0CRITICAL 9.8
  • TI-2025-16981 Apache Ambari: Code Injection Vulnerability in Ambari Alert Definition CVSS 3.1HIGH 8.8
  • TI-2024-34845 Apache Ambari: Remote Code Injection in Ambari Metrics and AMS Alerts CVSS 3.1HIGH 8.8
  • TI-2023-27565 Apache Ambari: authenticated users could perform command injection to perform RCE CVSS 3.1HIGH 8.8
See all 25 →

Sources