WordPress Squirrly SEO - Advanced Pack Plugin <= 2.3.8 is vulnerable to SQL Injection
Priority LOW 34CWE-89Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · None · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-89.
Summary
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Squirrly Squirrly SEO - Advanced Pack.This issue affects Squirrly SEO - Advanced Pack: from n/a before 2.4.02.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00541 45th percentileScored 2026-11-07
Fix Fixed Squirrly SEO - Advanced Pack (Squirrly): 2.4.02
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA Squirrly SEO - Advanced Pack (Squirrly) Fixed in 2.4.02
Timeline
- 2026-10-02 Threatist record created from CVE-2023-50854
- 2026-10-03 Alias added: GHSA-8qp6-rm76-vj9q
References
More cifi Seo Plugin By Squirrly Seo vulnerabilities
- TI-2024-06026 SEO Plugin by Squirrly SEO <= 12.3.19 - Authenticated (Contributor+) SQL Injection via url Parameter CVSS 3.1HIGH 8.8
- TI-2024-09739 SEO Plugin by Squirrly SEO < 12.3.21 - Editor+ Stored XSS CVSS 3.1LOW 3.5
- TI-2025-16664 WordPress SEO Plugin by Squirrly SEO plugin <= 12.4.03 - SQL Injection vulnerability CVSS 3.1HIGH 8.8
- TI-2024-28938 WordPress Squirrly SEO plugin <= 12.3.19 - SQL Injection vulnerability CVSS 3.1HIGH 8.8
- TI-2022-17844 WordPress SEO Plugin by Squirrly SEO Plugin <= 12.1.10 is vulnerable to Arbitrary File Upload CVSS 3.1HIGH 8.8
- TI-2025-18371 WordPress Squirrly SEO plugin <= 12.4.07 - Broken Access Control vulnerability CVSS 3.1HIGH 8.8
Sources
- CVE-2023-50854 · CVE Program
- CVE-2023-50854 · NVD
- FIRST EPSS
- GHSA-8qp6-rm76-vj9q · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences