Improper input validation in GitHub Enterprise Server
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-77.
Summary
A command injection vulnerability was identified in GitHub Enterprise Server that allowed an attacker with an editor role in the Management Console to gain admin SSH access to the appliance when configuring SAML settings. Exploitation of this vulnerability required access to the GitHub Enterprise Server instance and access to the Management Console with the editor role. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.12 and was fixed in versions 3.11.5, 3.10.7, 3.9.10, and 3.8.15. This vulnerability was reported via the GitHub Bug Bounty program https://bounty.github.com .
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GitHub | Enterprise Server | 3.8.0 to before 3.8.15; 3.9.0 to before 3.9.10; 3.10.0 to before 3.10.7; 3.11.0 to before 3.11.5 | 3.8.15, 3.9.10, 3.10.7, 3.11.5, 3.12 | Patch available | CNA |
- Enterprise Server VendorGitHub Affected 3.8.0 to before 3.8.15; 3.9.0 to before 3.9.10; 3.10.0 to before 3.10.7; 3.11.0 to before 3.11.5 Fixed in 3.8.15, 3.9.10, 3.10.7, 3.11.5, 3.12 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:github:enterprise_server:*:*:*:*:*:*:*:* | before 3.8.15; 3.9.0 to before 3.9.10; 3.10.0 to before 3.10.7; 3.11.0 to before 3.11.5 | Vulnerable | GitHub |
- cpe:2.3:a:github:enterprise_server:*:*:*:*:*:*:*:* Versions before 3.8.15; 3.9.0 to before 3.9.10; 3.10.0 to before 3.10.7; 3.11.0 to before 3.11.5 Vulnerable ·GitHub
Remediation
- Fix · CNA Enterprise Server (GitHub) Fixed in 3.8.15, 3.9.10, 3.10.7, 3.11.5, 3.12
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
GitHub Enterprise Server 3.10.7, 3.11.5 and 2 more versions
7 records Highest priority Priority MEDIUM 6 MEDIUM, 1 LOW
Other records, highest priority first
- TI-2024-01285 Improper input validation in GitHub Enterprise ServerPriority MEDIUM 46
- TI-2024-01281 Improper input validation in GitHub Enterprise ServerPriority MEDIUM 46
- TI-2024-01277 Improper input validation in GitHub Enterprise ServerPriority MEDIUM 46
Timeline
- 2026-10-02 Threatist record created from CVE-2024-1372
- 2026-10-03 Alias added: GHSA-pqfp-6wmf-23ch
References
More GitHub Enterprise Server vulnerabilities
- TI-2024-04632 An authentication bypass vulnerability was present in the GitHub Enterprise Server (GHES)… CVSS 4.0CRITICAL 10.0
- TI-2024-00181 Unsafe Reflection in Github Enterprise Server leading to Command Injection CVSS 3.1CRITICAL 9.8
- TI-2024-00466 Privilege Escalation by Code Injection in the Management Console in GitHub Enterprise Server CVSS 3.1HIGH 8.8
- TI-2026-03340 Remote code execution via git push option injection in GitHub Enterprise Server CVSS 4.0HIGH 8.7
- TI-2024-08804 Improper signature verification in GitHub Enterprise Server CVSS 4.0CRITICAL 9.5
- TI-2026-08177 Server-side request forgery in GitHub Enterprise Server CVSS 4.0CRITICAL 9.2
Sources
- CVE-2024-1372 · CVE Program
- CVE-2024-1372 · NVD
- FIRST EPSS
- GHSA-pqfp-6wmf-23ch · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences