Read the docs
TI-2024-01640 Aliases CVE-2024-1763GHSA-9x24-7fgc-x3vc

Missing authorization in roxnor Wp Social Login and Register Social Counter

Priority LOW 35CWE-862Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
Low · Low · None
Fix status
No fix listed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-862.

Summary

The Wp Social Login and Register Social Counter plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the /wp_social/v1/ REST API endpoint in all versions up to, and including, 3.0.0. This makes it possible for unauthenticated attackers to enable and disable certain providers for the social share and login features.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0044 38th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
roxnorWp Social Login and Register Social Counterup to 3.0.0—No fix listedCNA
  • Wp Social Login and Register Social Counter Vendorroxnor Affected up to 3.0.0 Fixed in — No fix listed CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:wpmet:wp_social_login_and_register_social_counter:*:*:*:*:*:wordpress:*:*up to 3.0.0Vulnerableroxnor
  • cpe:2.3:a:wpmet:wp_social_login_and_register_social_counter:*:*:*:*:*:wordpress:*:* Versions up to 3.0.0 Vulnerable ·roxnor

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-1763
  2. 2026-10-03 Alias added: GHSA-9x24-7fgc-x3vc

References

  • TI-2022-23364 WordPress Wp Social Plugin <= 1.9.0 is vulnerable to Sensitive Data Exposure CVSS 3.1MEDIUM 6.5
  • TI-2025-01295 Wp Social Login and Register Social Counter <= 3.1.0 - Cross-Site Request Forgery to Settings Update CVSS 3.1MEDIUM 4.3

Sources