Deserialization of untrusted data in wpWax Logo Showcase Ultimate – Logo Carousel, Logo…
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-502.
Summary
The Logo Showcase Ultimate – Logo Carousel, Logo Slider & Logo Grid plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 1.3.8 via deserialization via shortcode of untrusted input. This makes it possible for authenticated attackers, with contributor access and above, to inject a PHP Object. No POP chain is present in the vulnerable plugin. If a POP chain is present via an additional plugin or theme installed on the target system, it could allow the attacker to delete arbitrary files, retrieve sensitive data, or execute code.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-1951
- 2026-10-03 Alias added: GHSA-rvjq-cgm3-hvq9
References
Other 4
- https://www.wordfence.com/threat-intel/vulnerabilities/id/a63b2091-1502-4d9f-98c4-ce9d2f923dc4?source=cve
- https://plugins.trac.wordpress.org/browser/logo-showcase-ultimate/tags/1.3.8/classes/lcg-adl-metabox.php
- https://plugins.trac.wordpress.org/browser/logo-showcase-ultimate/tags/1.3.8/classes/lcg-shortcode.php
- https://plugins.trac.wordpress.org/changeset?old_path=/logo-showcase-ultimate/tags/1.3.8&old=3045923&new_path=/logo-showcase-ultimate/tags/1.3.9&new=3045923&sfp_email=&sfph_mail=
More wpWax vulnerabilities
- TI-2022-03630 Directorist < 7.4.4 - Subscriber+ Sensitive Information Disclosure CVSS 3.1MEDIUM 6.5
- TI-2022-03605 Directorist < 7.4.2.2 - Subscriber+ Arbitrary User Password Update via IDOR CVSS 3.1MEDIUM 6.5
- TI-2026-42481 WordPress Directorist plugin <= 8.8.2 - PHP Object Injection vulnerability CVSS 3.1CRITICAL 9.8
- TI-2025-23723 WordPress HelpGent plugin <= 2.2.5 - PHP Object Injection vulnerability CVSS 3.1CRITICAL 9.8
- TI-2024-01866 Deserialization of untrusted data in wpWax Post Grid, Slider & Carousel Ultimate – with… CVSS 3.1HIGH 8.8
- TI-2026-02713 FormGent <= 1.9.2- Missing Authorization to Unauthenticated Arbitrary File Deletion via 'file_token' Parameter CVSS 3.1CRITICAL 9.1
Sources
- CVE-2024-1951 · CVE Program
- CVE-2024-1951 · NVD
- FIRST EPSS
- GHSA-rvjq-cgm3-hvq9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences