Christmas Greetings <= 1.2.5 - Reflected Cross-Site Scripting
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
The Christmas Greetings plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the code parameter in all versions up to, and including, 1.2.5 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| technocrackers | Christmas Greetings | up to 1.2.5 | — | No fix listed | CNA |
- Christmas Greetings Vendortechnocrackers Affected up to 1.2.5 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-2116
- 2026-10-03 Alias added: GHSA-pxq6-w56g-vh78
References
More technocrackers vulnerabilities
- TI-2023-13183 Cross-site scripting in Woo Bulk Price Update WordPress Plugin CVSS 3.1MEDIUM 5.4
Sources
- CVE-2024-2116 · CVE Program
- CVE-2024-2116 · NVD
- FIRST EPSS
- GHSA-pxq6-w56g-vh78 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences