Elementor Website Builder Pro <= 3.20.1 - Authenticated (Contributor+) Stored Cross-Site Scripting
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
The Elementor Website Builder Pro plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's Media Carousel widget in all versions up to, and including, 3.20.1 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-2121
- 2026-10-03 Alias added: GHSA-9vgg-w578-gv86
References
More Elementor Pro vulnerabilities
- TI-2023-02927 Elementor Pro <= 3.11.6 - Authenticated(Subscriber+) Privilege Escalation via update_page_option CVSS 3.1HIGH 8.8
- TI-2020-16210 The Dynamic OOO widget for the Elementor Pro plugin through 3.0.5 for WordPress allows… CVSS 3.1HIGH 8.8
- TI-2024-23525 WordPress Elementor Pro <= 3.21.2 - Reflected Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
- TI-2024-02592 Cross-site scripting in Elementor Website Builder Pro CVSS 3.1MEDIUM 6.4
- TI-2024-01418 Cross-site scripting in Elementor Website Builder Pro CVSS 3.1MEDIUM 6.4
- TI-2024-01272 Elementor Website Builder Pro <= 3.20.1 - Authententicated (Contributor+) Stored Cross-Site Scripting CVSS 3.1MEDIUM 6.4
Sources
- CVE-2024-2121 · CVE Program
- CVE-2024-2121 · NVD
- FIRST EPSS
- GHSA-9vgg-w578-gv86 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences