WordPress Elementor Pro <= 3.21.2 - Reflected Cross Site Scripting (XSS) vulnerability
Priority LOW 31CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Elementor Elementor Pro allows Reflected XSS.This issue affects Elementor Pro: from n/a through 3.21.2.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00331 26th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-35656
- 2026-10-03 Alias added: GHSA-vcr8-r6c4-76qw
References
More Elementor Pro vulnerabilities
- TI-2023-02927 Elementor Pro <= 3.11.6 - Authenticated(Subscriber+) Privilege Escalation via update_page_option CVSS 3.1HIGH 8.8
- TI-2020-16210 The Dynamic OOO widget for the Elementor Pro plugin through 3.0.5 for WordPress allows… CVSS 3.1HIGH 8.8
- TI-2024-02592 Cross-site scripting in Elementor Website Builder Pro CVSS 3.1MEDIUM 6.4
- TI-2024-01418 Cross-site scripting in Elementor Website Builder Pro CVSS 3.1MEDIUM 6.4
- TI-2024-01272 Elementor Website Builder Pro <= 3.20.1 - Authententicated (Contributor+) Stored Cross-Site Scripting CVSS 3.1MEDIUM 6.4
- TI-2024-01971 Elementor Website Builder Pro <= 3.20.1 - Authenticated (Contributor+) Stored Cross-Site Scripting CVSS 3.1MEDIUM 5.4
Sources
- CVE-2024-35656 · CVE Program
- CVE-2024-35656 · NVD
- FIRST EPSS
- GHSA-vcr8-r6c4-76qw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences