A race condition was identified through which privilege escalation was possible in certain configurations.
Priority MEDIUM 40CWE-1223Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
A race condition was identified through which privilege escalation was possible in certain configurations.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00389 33rd percentileScored 2026-11-07
Fix Fixed Octopus Server (Octopus Deploy): 2023.4.8432, 2024.1.12087, 2024.2.2075
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Octopus Deploy | Octopus Server | 0.9 to before 2023.4.8432; 2024.1.437 to before 2024.1.12087; 2024.2.101 to before 2024.2.2075 | 2023.4.8432, 2024.1.12087, 2024.2.2075 | Patch available | CNA |
- Octopus Server VendorOctopus Deploy Affected 0.9 to before 2023.4.8432; 2024.1.437 to before 2024.1.12087; 2024.2.101 to before 2024.2.2075 Fixed in 2023.4.8432, 2024.1.12087, 2024.2.2075 Patch available CNA
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:octopus:octopus_server:*:*:*:*:*:*:*:* | 0.9 to before 2023.4.8432; 2024.1.437 to before 2024.1.12087; 2024.2.101 to before 2024.2.2075 | Vulnerable | Octopus Deploy |
| cpe:2.3:o:linux:linux_kernel:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Linux |
| cpe:2.3:o:microsoft:windows:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Microsoft |
- cpe:2.3:a:octopus:octopus_server:*:*:*:*:*:*:*:* Versions 0.9 to before 2023.4.8432; 2024.1.437 to before 2024.1.12087; 2024.2.101 to before 2024.2.2075 Vulnerable ·Octopus Deploy
- cpe:2.3:o:linux:linux_kernel:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Linux
- cpe:2.3:o:microsoft:windows:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Microsoft
Remediation
- Fix · CNA Octopus Server (Octopus Deploy) Fixed in 2023.4.8432, 2024.1.12087, 2024.2.2075
Timeline
- 2026-10-02 Threatist record created from CVE-2024-2975
- 2026-10-03 Alias added: GHSA-8qhf-fjfw-g5r8
References
More Octopus Deploy Octopus Server vulnerabilities
- TI-2018-13353 In Octopus Deploy 2018.8.0 through 2018.9.x before 2018.9.1, an authenticated user with… CVSS 3.0HIGH 8.8
- TI-2022-02375 Improper authentication in Octopus Server CVSS 3.1CRITICAL 9.8
- TI-2022-02579 Insufficient session expiration in Octopus Server CVSS 3.1CRITICAL 9.1
- TI-2018-08066 In Octopus Deploy 2018.4.4 through 2018.5.1, Octopus variables that are sourced from the… CVSS 3.0CRITICAL 9.8
- TI-2022-02575 In affected versions of Octopus Deploy it is possible to bypass rate limiting on login using null bytes. CVSS 3.1CRITICAL 9.8
- TI-2022-03678 In affected versions of Octopus Deploy it is possible for a user to introduce code via offline package creation CVSS 3.1HIGH 8.8
Sources
- CVE-2024-2975 · CVE Program
- CVE-2024-2975 · NVD
- FIRST EPSS
- GHSA-8qhf-fjfw-g5r8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences