Exposure of Sensitive Information in lunary-ai/lunary
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-922.
Summary
In lunary-ai/lunary versions up to and including 1.2.5, an information disclosure vulnerability exists due to the inclusion of single-use tokens in the responses of `GET /v1/users/me` and `GET /v1/users/me/org` API endpoints. These tokens, intended for sensitive operations such as password resets or account verification, are exposed to unauthorized actors, potentially allowing them to perform actions on behalf of the user. This issue was addressed in version 1.2.6, where the exposure of single-use tokens in user-facing queries was mitigated.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA lunary-ai/lunary (lunary-ai) Fixed in 1.2.6
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
lunary-ai/lunary 1.2.6
2 records Highest priority Priority HIGH 2 HIGH
Other records, highest priority first
- TI-2024-03267 Exposure of Sensitive Information in lunary-ai/lunaryPriority HIGH 80
Timeline
- 2026-10-02 Threatist record created from CVE-2024-3501
- 2026-10-03 Alias added: GHSA-36g3-5c2m-mrqx
References
More lunary-ai Lunary vulnerabilities
- TI-2024-08445 Improper Authorization in lunary-ai/lunary CVSS 3.1CRITICAL 9.8
- TI-2024-06910 SQL Injection in lunary-ai/lunary CVSS 3.1CRITICAL 9.8
- TI-2024-03859 Incorrect Authorization in lunary-ai/lunary CVSS 3.1CRITICAL 9.8
- TI-2024-06928 Improper Access Control in lunary-ai/lunary CVSS 3.1CRITICAL 9.1
- TI-2024-03267 Exposure of Sensitive Information in lunary-ai/lunary CVSS 3.1CRITICAL 9.1
- TI-2024-01619 Improper Authorization in lunary-ai/lunary CVSS 3.1CRITICAL 9.1
Sources
- CVE-2024-3501 · CVE Program
- CVE-2024-3501 · NVD
- FIRST EPSS
- GHSA-36g3-5c2m-mrqx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences