Read the docs
TI-2024-01619 Aliases CVE-2024-1741GHSA-v6wm-cwm9-2486

Improper Authorization in lunary-ai/lunary

Priority HIGH 80CWE-863Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
High · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-863.

Summary

lunary-ai/lunary version 1.0.1 is vulnerable to improper authorization, allowing removed members to read, create, modify, and delete prompt templates using an old authorization token. Despite being removed from an organization, these members can still perform operations on prompt templates by sending HTTP requests with their previously captured authorization token. This issue exposes organizations to unauthorized access and manipulation of sensitive template data.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00586 48th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed lunary-ai/lunary (lunary-ai): 1.2.8

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
Yes
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
lunary-ailunary-ai/lunarybefore 1.2.81.2.8Patch availableCNA
  • lunary-ai/lunary Vendorlunary-ai Affected before 1.2.8 Fixed in 1.2.8 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:lunary:lunary:*:*:*:*:*:*:*:*before 1.2.8Vulnerablelunary-ai
  • cpe:2.3:a:lunary:lunary:*:*:*:*:*:*:*:* Versions before 1.2.8 Vulnerable ·lunary-ai

Remediation

  • Fix · CNA lunary-ai/lunary (lunary-ai) Fixed in 1.2.8

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    lunary-ai/lunary 1.2.8

    2 records Highest priority Priority HIGH 2 HIGH

    Other records, highest priority first

    • TI-2024-01771 Session Reuse Vulnerability in lunary-ai/lunaryPriority HIGH 72

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-1741
  2. 2026-10-03 Alias added: GHSA-v6wm-cwm9-2486

References

  • TI-2024-08445 Improper Authorization in lunary-ai/lunary CVSS 3.1CRITICAL 9.8
  • TI-2024-06910 SQL Injection in lunary-ai/lunary CVSS 3.1CRITICAL 9.8
  • TI-2024-03859 Incorrect Authorization in lunary-ai/lunary CVSS 3.1CRITICAL 9.8
  • TI-2024-06928 Improper Access Control in lunary-ai/lunary CVSS 3.1CRITICAL 9.1
  • TI-2024-03267 Exposure of Sensitive Information in lunary-ai/lunary CVSS 3.1CRITICAL 9.1
  • TI-2024-03266 Exposure of Sensitive Information in lunary-ai/lunary CVSS 3.1CRITICAL 9.1
See all 68 →

Sources