Read the docs

lunary-ai

Records71All Threatist records
Exploited (KEV)0None in CISA KEV
CVSS critical13CVSS 9.0–10.0
CVSS high30CVSS 7.0–8.9

Exploited now

lunary-ai records in CISA KEV

No lunary-ai vulnerabilities are listed in CISA KEV.

Components

Products in the NVD configurations · select one to filter the records

Records

71 records

TI-2024-08445 CVE-2024-9095 · GHSA-j4mc-gwfc-jcf5

Improper Authorization in lunary-ai/lunary

Priority HIGH 82

In lunary-ai/lunary version v1.4.28, the /bigquery API route lacks proper access control, allowing any logged-in user to create a Datastream to Google BigQuery and export the entire database.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.00734 Published 2025-03-20 Fixed in 1.4.30 CWE-862
TI-2024-06910 CVE-2024-7456 · GHSA-g58p-2mpf-2cpr

SQL Injection in lunary-ai/lunary

Priority HIGH 82

A SQL injection vulnerability exists in the `/api/v1/external-users` route of lunary-ai/lunary version v1.4.2.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.0141 Published 2024-11-01 Fixed in 1.4.3 CWE-89
Priority HIGH 82

In lunary-ai/lunary version v1.2.13, an incorrect authorization vulnerability exists that allows unauthorized users to access and manipulate projects within an organization they should not have access to.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.00542 Published 2024-06-08 Fixed in 1.2.26 CWE-863
Priority HIGH 80

An improper access control vulnerability in lunary-ai/lunary version 1.3.2 allows an attacker to update the SAML configuration without authorization.

CVSS 3.1CRITICAL 9.1 Network No auth No interaction EPSS 0.00725 Published 2024-10-29 Fixed in 1.3.4 CWE-862
Priority HIGH 80

In lunary-ai/lunary versions up to and including 1.2.5, an information disclosure vulnerability exists where account recovery hashes of users are inadvertently exposed to unauthorized actors.

CVSS 3.1CRITICAL 9.1 Network No auth No interaction EPSS 0.00409 Published 2024-11-14 Fixed in 1.2.6 CWE-201
Priority HIGH 80

In lunary-ai/lunary versions up to and including 1.2.5, an information disclosure vulnerability exists due to the inclusion of single-use tokens in the responses of `GET /v1/users/me` and `GET /v1/users/me/org` API endpo…

CVSS 3.1CRITICAL 9.1 Network No auth No interaction EPSS 0.00412 Published 2024-11-14 Fixed in 1.2.6 CWE-922
TI-2024-01619 CVE-2024-1741 · GHSA-v6wm-cwm9-2486

Improper Authorization in lunary-ai/lunary

Priority HIGH 80

lunary-ai/lunary version 1.0.1 is vulnerable to improper authorization, allowing removed members to read, create, modify, and delete prompt templates using an old authorization token.

CVSS 3.1CRITICAL 9.1 Network No auth No interaction EPSS 0.00586 Published 2024-04-10 Fixed in 1.2.8 CWE-863
Priority HIGH 80

By knowing an organization's ID, an attacker can join the organization without permission and gain the ability to read and modify all data within that organization.

CVSS 3.0CRITICAL 9.1 Network No auth No interaction EPSS 0.0068 Published 2024-04-10 Fixed in 1.2.2 CWE-200
TI-2024-04947 CVE-2024-5328 · GHSA-fmgc-qjr6-w2jp

SSRF Vulnerability in lunary-ai/lunary

Priority HIGH 79

A Server-Side Request Forgery (SSRF) vulnerability exists in the lunary-ai/lunary application, specifically within the endpoint '/auth/saml/tto/download-idp-xml'.

CVSS 3.1CRITICAL 9.3 Network No auth No interaction EPSS 0.00417 Published 2024-06-06 No fix listed CWE-918
TI-2024-04764 CVE-2024-5128 · GHSA-7g45-4xm2-qxvf

IDOR Vulnerability in lunary-ai/lunary

Priority HIGH 79

An Insecure Direct Object Reference (IDOR) vulnerability was identified in lunary-ai/lunary, affecting versions up to and including 1.2.2.

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.00509 Published 2024-06-06 Fixed in 1.2.25 CWE-639
Priority HIGH 76

A critical stored Cross-Site Scripting (XSS) vulnerability exists in the Analytics component of lunary-ai/lunary versions up to 1.9.23, where the NEXT_PUBLIC_CUSTOM_SCRIPT environment variable is directly injected into t…

CVSS 3.1CRITICAL 9.6 Network No auth User interaction EPSS 0.00497 Published 2025-08-23 Fixed in 1.9.25 CWE-79
Priority HIGH 76

In lunary-ai/lunary version 1.2.4, an account takeover vulnerability exists due to the exposure of password recovery tokens in API responses.

CVSS 3.1HIGH 8.1 Network Low privileges No interaction EPSS 0.00543 Published 2024-06-06 No fix listed CWE-200
Priority HIGH 76

In lunary-ai/lunary versions 1.2.2 through 1.2.6, an incorrect authorization vulnerability allows unprivileged users to re-generate the private key for projects they do not have access to.

CVSS 3.1CRITICAL 9.6 Network Low privileges No interaction EPSS 0.00394 Published 2024-11-14 Fixed in 1.2.7 CWE-863
Priority HIGH 75

A Privilege Escalation Vulnerability exists in lunary-ai/lunary version 1.2.2, where any user can delete any datasets due to missing authorization checks.

CVSS 3.1HIGH 8.2 Network No auth No interaction EPSS 0.0045 Published 2024-06-06 Fixed in 1.2.8 CWE-862
Priority HIGH 74

lunary-ai/lunary version v1.4.25 contains an improper access control vulnerability in the POST /api/v1/data-warehouse/bigquery endpoint.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.0081 Published 2025-03-20 Fixed in 1.4.26 CWE-862
TI-2024-01510 CVE-2024-1626 · GHSA-4x7q-prxg-7hxw

IDOR Vulnerability in lunary-ai/lunary

Priority HIGH 74

An Insecure Direct Object Reference (IDOR) vulnerability exists in the lunary-ai/lunary repository, version 0.3.0, within the project update endpoint.

CVSS 3.1HIGH 8.1 Network Low privileges No interaction EPSS 0.00479 Published 2024-04-16 Fixed in 1.0.0 CWE-639
Priority HIGH 73

lunary-ai/lunary version 1.9.34 is vulnerable to an account takeover due to improper authentication in the Google OAuth integration.

CVSS 3.1HIGH 8.8 Network No auth User interaction EPSS 0.00461 Published 2025-11-25 Fixed in 1.9.35 CWE-287
TI-2024-09517 CVE-2024-10272 · GHSA-69j6-4w2p-2887

Broken Access Control in lunary-ai/lunary

Priority HIGH 72

lunary-ai/lunary is vulnerable to broken access control in the latest version.

CVSS 3.0HIGH 7.5 Network No auth No interaction EPSS 0.00607 Published 2025-03-20 Fixed in 1.4.9 CWE-862
TI-2024-08130 CVE-2024-8764 · GHSA-j8x9-qc9m-rmhj

Improper Authorization in lunary-ai/lunary

Priority HIGH 72

A vulnerability in lunary-ai/lunary, as of commit be54057, allows users to upload and execute arbitrary regular expressions on the server side.

CVSS 3.0HIGH 7.5 Network No auth No interaction EPSS 0.00824 Published 2025-03-20 Fixed in 1.4.23 CWE-1333
Priority HIGH 72

A Regular Expression Denial of Service (ReDoS) vulnerability exists in the lunary-ai/lunary repository, specifically in the compileTextTemplate function.

CVSS 3.0HIGH 7.5 Network No auth No interaction EPSS 0.00824 Published 2025-03-20 Fixed in 1.4.23 CWE-1333
Load more
Open these records in search →