Read the docs
TI-2024-03507 Aliases CVE-2024-3761GHSA-56p3-wxg9-vx4g

Missing Authorization on Delete Datasets in lunary-ai/lunary

Priority LOW 39CWE-862Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
None · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-862.

Summary

In lunary-ai/lunary version 1.2.2, the DELETE endpoint located at `packages/backend/src/api/v1/datasets` is vulnerable to unauthorized dataset deletion due to missing authorization and authentication mechanisms. This vulnerability allows any user, even those without a valid token, to delete a dataset by sending a DELETE request to the endpoint. The issue was fixed in version 1.2.8. The impact of this vulnerability is significant as it permits unauthorized users to delete datasets, potentially leading to data loss or disruption of service.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0047 40th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed lunary-ai/lunary (lunary-ai): 1.2.8

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
lunary-ailunary-ai/lunarybefore 1.2.81.2.8Patch availableCNA
  • lunary-ai/lunary Vendorlunary-ai Affected before 1.2.8 Fixed in 1.2.8 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:lunary:lunary:*:*:*:*:*:*:*:*before 1.2.8Vulnerablelunary-ai
  • cpe:2.3:a:lunary:lunary:*:*:*:*:*:*:*:* Versions before 1.2.8 Vulnerable ·lunary-ai

Remediation

  • Fix · CNA lunary-ai/lunary (lunary-ai) Fixed in 1.2.8

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-3761
  2. 2026-10-03 Alias added: GHSA-56p3-wxg9-vx4g

References

  • TI-2024-08445 Improper Authorization in lunary-ai/lunary CVSS 3.1CRITICAL 9.8
  • TI-2024-06910 SQL Injection in lunary-ai/lunary CVSS 3.1CRITICAL 9.8
  • TI-2024-03859 Incorrect Authorization in lunary-ai/lunary CVSS 3.1CRITICAL 9.8
  • TI-2024-06928 Improper Access Control in lunary-ai/lunary CVSS 3.1CRITICAL 9.1
  • TI-2024-03267 Exposure of Sensitive Information in lunary-ai/lunary CVSS 3.1CRITICAL 9.1
  • TI-2024-03266 Exposure of Sensitive Information in lunary-ai/lunary CVSS 3.1CRITICAL 9.1
See all 68 →

Sources