tagDiv Composer <= 4.8 - Authenticated (Contributor+) Stored Cross-Site Scripting via button Shortcode
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
The tagDiv Composer plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's button shortcode in all versions up to, and including, 4.8 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. NOTE: The vulnerable code in this plugin is specifically tied to the tagDiv Newspaper theme. If another theme is installed (e.g., NewsMag), this code may not be present.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-3888
- 2026-10-03 Alias added: GHSA-3fv4-c2qp-rmpj
References
More tagDiv vulnerabilities
- TI-2022-03209 tagDiv Composer < 3.5 - Unauthenticated Account Takeover CVSS 3.1CRITICAL 9.8
- TI-2023-01506 tagDiv Cloud Library < 2.7 - Unauthenticated Arbitrary User Metadata Update to Privilege Escalation CVSS 3.1HIGH 8.8
- TI-2023-02969 tagDiv Composer < 4.2 - Unauthenticated Stored XSS CVSS 3.1MEDIUM 6.1
- TI-2023-01505 tagDiv Composer < 4.0 - Reflected Cross-site Scripting CVSS 3.1MEDIUM 6.1
- TI-2022-02429 Newspaper < 12 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
- TI-2022-02005 Newspaper < 12 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
Sources
- CVE-2024-3888 · CVE Program
- CVE-2024-3888 · NVD
- FIRST EPSS
- GHSA-3fv4-c2qp-rmpj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences