Bulk Posts Editing For WordPress <= 4.2.3 - Authenticated (Subscriber+) Missing Authorization
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-862.
Summary
The Bulk Posts Editing For WordPress plugin for WordPress is vulnerable to unauthorized access of functionality due to a missing capability check on the plugin's AJAX actions in all versions up to, and including, 4.2.3. This makes it possible for authenticated attackers, with subscriber access and higher, to invoke their corresponding functions. This may lead to post creation and duplication, post content retrieval, post taxonomy manipulation.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| ithemelandco | WPBULKiT – Bulk Edit WordPress Posts & Pages | up to 4.2.3 | — | No fix listed | CNA |
- WPBULKiT – Bulk Edit WordPress Posts & Pages Vendorithemelandco Affected up to 4.2.3 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-4199
- 2026-10-03 Alias added: GHSA-gw4x-f295-2jpv
References
Other 2
- https://www.wordfence.com/threat-intel/vulnerabilities/id/683131a0-eec3-4251-b322-5c2088855687?source=cve
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&new=3085134%40ithemeland-bulk-posts-editing-lite%2Ftrunk&old=2946926%40ithemeland-bulk-posts-editing-lite%2Ftrunk&sfp_email=&sfph_mail=
More ithemelandco vulnerabilities
- TI-2024-09926 WooCommerce Report <= 1.5.1 - Cross-Site Request Forgery to Arbitrary Options Update CVSS 3.1HIGH 8.8
- TI-2024-25918 WordPress WooCommerce Report plugin <= 1.4.5 - Reflected Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
- TI-2026-83268 Cross-site scripting in GIFTiT Free Gifts for WooCommerce CVSS 3.1MEDIUM 5.3
- TI-2024-03911 Bulk Posts Editing For WordPress <= 4.2.3 - Cross-Site Request Forgery CVSS 3.1MEDIUM 4.3
Sources
- CVE-2024-4199 · CVE Program
- CVE-2024-4199 · NVD
- FIRST EPSS
- GHSA-gw4x-f295-2jpv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences