Cross-site scripting in GIFTiT Free Gifts for WooCommerce
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-80.
Summary
The ithemelandco GIFTiT Free Gifts for WooCommerce plugin, from n/a through 4.5, does not neutralize script-related HTML tags in web pages (CWE-80). An unauthenticated remote attacker can inject script that runs in the affected page without user interaction, with a low impact on confidentiality.
Written with Claude Haiku 5.5 from the sources below · 2026-10-31
Description from the CNA
Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) vulnerability in ithemelandco GIFTiT – Free Gifts for WooCommerce ithemeland-free-gifts-for-woo allows Code Injection.This issue affects GIFTiT – Free Gifts for WooCommerce: from n/a through 4.5.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| ithemelandco | GIFTiT – Free Gifts for WooCommerce | up to 4.5 | — | No fix listed | CNA |
- GIFTiT – Free Gifts for WooCommerce Vendorithemelandco Affected up to 4.5 Fixed in — No fix listed CNA
Remediation
The sources list no fixed version for GIFTiT Free Gifts for WooCommerce.
Written with Claude Haiku 5.5 from the sources below · 2026-10-31
Timeline
- 2026-10-30 Threatist record created from CVE-2026-52710
- 2026-10-30 CISA SSVC decision points changed
- 2026-10-30 Alias added: GHSA-56mc-w4mj-q72x
More ithemelandco vulnerabilities
- TI-2024-09926 WooCommerce Report <= 1.5.1 - Cross-Site Request Forgery to Arbitrary Options Update CVSS 3.1HIGH 8.8
- TI-2024-25918 WordPress WooCommerce Report plugin <= 1.4.5 - Reflected Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
- TI-2024-03906 Bulk Posts Editing For WordPress <= 4.2.3 - Authenticated (Subscriber+) Missing Authorization CVSS 3.1MEDIUM 4.3
- TI-2024-03911 Bulk Posts Editing For WordPress <= 4.2.3 - Cross-Site Request Forgery CVSS 3.1MEDIUM 4.3
Sources
- CVE-2026-52710 · CVE Program
- CVE-2026-52710 · NVD
- FIRST EPSS
- GHSA-56mc-w4mj-q72x · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences