Cross-site scripting in Octopus Server
Priority LOW 24CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
In affected versions of Octopus Server with certain access levels it was possible to embed a Cross-Site Scripting payload on the audit page.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00255 17th percentileScored 2026-11-07
Fix Fixed Octopus Server (Octopus Deploy): 2023.3.13361, 2023.4.8338, 2024.1.11127
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Octopus Deploy | Octopus Server | 3.0 to before 2023.3.13361; 2023.4.296 to before 2023.4.8338; 2024.1.437 to before 2024.1.11127 | 2023.3.13361, 2023.4.8338, 2024.1.11127 | Patch available | CNA |
- Octopus Server VendorOctopus Deploy Affected 3.0 to before 2023.3.13361; 2023.4.296 to before 2023.4.8338; 2024.1.437 to before 2024.1.11127 Fixed in 2023.3.13361, 2023.4.8338, 2024.1.11127 Patch available CNA
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:octopus:octopus_server:*:*:*:*:*:*:*:* | 3.0.0 to before 2023.4.8338; 2024.1.437 to before 2024.1.11127 | Vulnerable | Octopus Deploy |
| cpe:2.3:o:linux:linux_kernel:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Linux |
| cpe:2.3:o:microsoft:windows:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Microsoft |
- cpe:2.3:a:octopus:octopus_server:*:*:*:*:*:*:*:* Versions 3.0.0 to before 2023.4.8338; 2024.1.437 to before 2024.1.11127 Vulnerable ·Octopus Deploy
- cpe:2.3:o:linux:linux_kernel:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Linux
- cpe:2.3:o:microsoft:windows:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Microsoft
Remediation
- Fix · CNA Octopus Server (Octopus Deploy) Fixed in 2023.3.13361, 2023.4.8338, 2024.1.11127
Timeline
- 2026-10-02 Threatist record created from CVE-2024-4456
- 2026-10-03 Alias added: GHSA-594v-v6mq-rw7x
References
More Octopus Deploy Octopus Server vulnerabilities
- TI-2018-13353 In Octopus Deploy 2018.8.0 through 2018.9.x before 2018.9.1, an authenticated user with… CVSS 3.0HIGH 8.8
- TI-2022-02375 Improper authentication in Octopus Server CVSS 3.1CRITICAL 9.8
- TI-2022-02579 Insufficient session expiration in Octopus Server CVSS 3.1CRITICAL 9.1
- TI-2018-08066 In Octopus Deploy 2018.4.4 through 2018.5.1, Octopus variables that are sourced from the… CVSS 3.0CRITICAL 9.8
- TI-2022-02575 In affected versions of Octopus Deploy it is possible to bypass rate limiting on login using null bytes. CVSS 3.1CRITICAL 9.8
- TI-2022-03678 In affected versions of Octopus Deploy it is possible for a user to introduce code via offline package creation CVSS 3.1HIGH 8.8
Sources
- CVE-2024-4456 · CVE Program
- CVE-2024-4456 · NVD
- FIRST EPSS
- GHSA-594v-v6mq-rw7x · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences