WordPress Automatic <= 3.94.0 - Authenticated (Contributor+) Stored Cross-Site Scripting via autoplay Parameter
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
The WordPress Automatic Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘autoplay’ parameter in all versions up to, and including, 3.94.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| ValvePress | WordPress Automatic Plugin | up to 3.94.0 | — | No fix listed | CNA |
- WordPress Automatic Plugin VendorValvePress Affected up to 3.94.0 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-4849
- 2026-10-03 Alias added: GHSA-c7gm-g64m-839f
References
More ValvePress vulnerabilities
- TI-2024-18559 WordPress Automatic plugin <= 3.92.0 - Unauthenticated Arbitrary SQL Execution vulnerability CVSS 3.1CRITICAL 9.9
- TI-2021-03231 WordPress Automatic Plugin <= 3.53.2 - Unauthenticated Arbitrary Options Update CVSS 3.1CRITICAL 9.8
- TI-2021-03237 Pinterest Automatic <= 4.14.3 - Unuathenticated Arbitrary Options Update CVSS 3.1CRITICAL 9.8
- TI-2025-26252 WordPress Pinterest Automatic Pin plugin < 4.19.0 - SQL Injection vulnerability CVSS 3.1HIGH 8.5
- TI-2025-04847 Unrestricted file upload in ValvePress WordPress Automatic Plugin CVSS 3.1HIGH 8.8
- TI-2025-26235 WordPress Rankie plugin < 1.8.2 - Broken Access Control Vulnerability CVSS 3.1HIGH 8.8
Sources
- CVE-2024-4849 · CVE Program
- CVE-2024-4849 · NVD
- FIRST EPSS
- GHSA-c7gm-g64m-839f · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences