Read the docs
TI-2024-04520 Aliases CVE-2024-4860GHSA-p7q5-4hfm-m8fh

Cross-site scripting in wp-rss-aggregator

Priority LOW 27CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.

Summary

The 'WordPress RSS Aggregator' WordPress Plugin, versions < 4.23.9 are affected by a Cross-Site Scripting (XSS) vulnerability due to the lack of sanitization of the  'notice_id'  GET parameter.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00382 32nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed wp-rss-aggregator: 4.23.9

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
—wp-rss-aggregatorbefore 4.23.94.23.9Patch availableCNA
  • wp-rss-aggregator Vendor— Affected before 4.23.9 Fixed in 4.23.9 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:rebelcode:rss_aggregator:*:*:*:*:*:wordpress:*:*before 4.23.9Vulnerablerebelcode
  • cpe:2.3:a:rebelcode:rss_aggregator:*:*:*:*:*:wordpress:*:* Versions before 4.23.9 Vulnerable ·rebelcode

Remediation

  • Fix · CNA wp-rss-aggregator Fixed in 4.23.9

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-4860
  2. 2026-10-03 Alias added: GHSA-p7q5-4hfm-m8fh

References

  • TI-2024-08890 RSS Aggregator – RSS Import, News Feeds, Feed to Post, and Autoblogging <= 4.23.12 - Missing Authorization CVSS 3.1MEDIUM 5.4
  • TI-2024-06141 WP RSS Aggregator <= 4.23.11 - Missing Authorization to Authenticated (Subscriber+) Feed State Update CVSS 3.1MEDIUM 4.3

Sources