RSS Aggregator – RSS Import, News Feeds, Feed to Post, and Autoblogging <= 4.23.12 - Missing Authorization
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-862.
Summary
The RSS Aggregator – RSS Import, News Feeds, Feed to Post, and Autoblogging plugin for WordPress is vulnerable to unauthorized use of functionality due to a missing capability check on the wprss_ajax_send_premium_support function in all versions up to, and including, 4.23.12. This makes it possible for authenticated attackers, with Subscriber-level access and above, to send premium support requests with an attacker-controlled subject line and email address to support allowing them to impersonate the site owner. License information may also be leaked.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| rebelcode | RSS Aggregator – RSS Import, News Feeds, Feed to Post, and Autoblogging | up to 4.23.12 | — | No fix listed | CNA |
- RSS Aggregator – RSS Import, News Feeds, Feed to Post, and Autoblogging Vendorrebelcode Affected up to 4.23.12 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-9583
- 2026-10-03 Alias added: GHSA-6fjr-qhr8-g6mc
References
Patch 1
More rebelcode Rss Aggregator vulnerabilities
- TI-2024-04520 Cross-site scripting in wp-rss-aggregator CVSS 3.1MEDIUM 6.1
- TI-2024-06141 WP RSS Aggregator <= 4.23.11 - Missing Authorization to Authenticated (Subscriber+) Feed State Update CVSS 3.1MEDIUM 4.3
Sources
- CVE-2024-9583 · CVE Program
- CVE-2024-9583 · NVD
- FIRST EPSS
- GHSA-6fjr-qhr8-g6mc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences