Improper Access Control in lunary-ai/lunary
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-639.
Summary
An Improper Access Control vulnerability exists in the lunary-ai/lunary repository, affecting versions up to and including 1.2.2. The vulnerability allows unauthorized users to view any prompts in any projects by supplying a specific prompt ID to an endpoint that does not adequately verify the ownership of the prompt ID. This issue was fixed in version 1.2.25.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA lunary-ai/lunary (lunary-ai) Fixed in 1.2.25
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
lunary-ai/lunary 1.2.25
4 records Highest priority Priority HIGH 2 HIGH, 2 MEDIUM
Other records, highest priority first
- TI-2024-04764 IDOR Vulnerability in lunary-ai/lunaryPriority HIGH 79
- TI-2024-04762 Improper Access Control in lunary-ai/lunaryPriority MEDIUM 62
- TI-2024-04763 Improper Access Control in lunary-ai/lunaryPriority MEDIUM 58
Timeline
- 2026-10-02 Threatist record created from CVE-2024-5131
- 2026-10-03 Alias added: GHSA-wm2w-xpgv-w6v4
References
More lunary-ai Lunary vulnerabilities
- TI-2024-08445 Improper Authorization in lunary-ai/lunary CVSS 3.1CRITICAL 9.8
- TI-2024-06910 SQL Injection in lunary-ai/lunary CVSS 3.1CRITICAL 9.8
- TI-2024-03859 Incorrect Authorization in lunary-ai/lunary CVSS 3.1CRITICAL 9.8
- TI-2024-06928 Improper Access Control in lunary-ai/lunary CVSS 3.1CRITICAL 9.1
- TI-2024-03267 Exposure of Sensitive Information in lunary-ai/lunary CVSS 3.1CRITICAL 9.1
- TI-2024-03266 Exposure of Sensitive Information in lunary-ai/lunary CVSS 3.1CRITICAL 9.1
Sources
- CVE-2024-5131 · CVE Program
- CVE-2024-5131 · NVD
- FIRST EPSS
- GHSA-wm2w-xpgv-w6v4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences