Remote Code Execution in BerriAI/litellm
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-94.
Summary
BerriAI/litellm version v1.35.8 contains a vulnerability where an attacker can achieve remote code execution. The vulnerability exists in the `add_deployment` function, which decodes and decrypts environment variables from base64 and assigns them to `os.environ`. An attacker can exploit this by sending a malicious payload to the `/config/update` endpoint, which is then processed and executed by the server when the `get_secret` function is triggered. This requires the server to use Google KMS and a database to store a model.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| BerriAI | berriai/litellm | up to latest | — | No fix listed | CNA |
| — | litellm (PyPI) | before 1.40.16 | 1.40.16 | Patch available | GHSA-gppg-gqw8-wh9g |
- berriai/litellm VendorBerriAI Affected up to latest Fixed in — No fix listed CNA
- litellm (PyPI) Vendor— Affected before 1.40.16 Fixed in 1.40.16 Patch available GHSA-gppg-gqw8-wh9g
Remediation
- Fix · GHSA-gppg-gqw8-wh9g litellm (PyPI) Fixed in 1.40.16 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-5751
- 2026-10-03 Alias added: GHSA-gppg-gqw8-wh9g
References
More BerriAI Litellm vulnerabilities
- TI-2026-26015 Trivy ecosystem supply chain briefly compromised KEVCVSS 4.0CRITICAL 9.4
- TI-2026-30529 LiteLLM: SQL injection in Proxy API key verification KEVCVSS 4.0CRITICAL 9.3
- TI-2026-30582 LiteLLM: Authenticated command execution via MCP stdio test endpoints KEVCVSS 4.0HIGH 8.7
- TI-2026-42639 LiteLLM: MCP Authentication Bypass via OAuth2 Passthrough Fallback KEVCVSS 4.0HIGH 8.8
- TI-2024-02760 Server-Side Template Injection in BerriAI/litellm CVSS 3.0CRITICAL 9.8
- TI-2026-34701 LiteLLM < 1.83.10 Privilege Escalation via User Update CVSS 4.0HIGH 8.7
Sources
- CVE-2024-5751 · CVE Program
- CVE-2024-5751 · NVD
- FIRST EPSS
- GHSA-gppg-gqw8-wh9g · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences