Priority CRITICAL 100KEV
Trivy is a security scanner.
CVSS 4.0CRITICAL 9.4· Network · Low privileges · No interaction · EPSS 0.59727 · Published 2026-03-23 · Fixed in 0.2.6, 0.35.0 CWE-506
Priority CRITICAL 99KEV
LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format.
CVSS 4.0CRITICAL 9.3· Network · No auth · No interaction · EPSS 0.8942 · Published 2026-05-08 · Fixed in 1.83.7 CWE-89
Priority CRITICAL 97KEV
LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format.
CVSS 4.0HIGH 8.7· Network · Low privileges · No interaction · EPSS 0.91445 · Published 2026-05-08 · Fixed in 1.83.7 CWE-77
Priority CRITICAL 95KEV
LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format.
CVSS 4.0HIGH 8.8· Network · No auth · No interaction · EPSS 0.00836 · Published 2026-07-08 · Fixed in 1.84.0 CWE-287
Priority HIGH 82
BerriAI/litellm version v1.35.8 contains a vulnerability where an attacker can achieve remote code execution.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.00882 · Published 2024-06-27 · Fixed in 1.40.16 CWE-94
Priority HIGH 82
BerriAI/litellm is vulnerable to Server-Side Template Injection (SSTI) via the `/completions` endpoint.
CVSS 3.0CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.01267 · Published 2024-04-10 · Fixed in 1.34.42 CWE-76
Priority HIGH 73
LiteLLM prior to 1.83.10 allows a user to modify their own user_role via the /user/update endpoint.
CVSS 4.0HIGH 8.7· Network · Low privileges · No interaction · EPSS 0.00654 · Published 2026-05-21 · Partial fix · 1.83.10 CWE-863
Priority HIGH 73
LiteLLM prior to 1.83.14 allows an authenticated internal_user to create API keys with access to routes that their role does not permit.
CVSS 4.0HIGH 8.7· Network · Low privileges · No interaction · EPSS 0.01185 · Published 2026-05-21 · Partial fix · 1.83.14 CWE-863
Priority HIGH 73
LiteLLM through 2026-04-08 allows remote attackers to execute arbitrary code via bytecode rewriting at the /guardrails/test_custom_code URI.
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.1702 · Published 2026-04-10 · Partial fix · 1.83.10 CWE-420
Priority HIGH 73
BerriAI/litellm version 1.40.12 contains a vulnerability that allows remote code execution.
CVSS 3.0HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.0165 · Published 2025-03-20 · Fixed in v1.65.4.dev6 CWE-94
Priority HIGH 72
In berriai/litellm version v1.52.1, an issue in proxy_server.py causes the leakage of Langfuse API keys when an error occurs while parsing team settings.
CVSS 3.0HIGH 7.5· Network · No auth · No interaction · EPSS 0.00566 · Published 2025-03-20 · No fix listed CWE-1230
Priority HIGH 72
In berriai/litellm before version 1.44.12, the `litellm/litellm_core_utils/litellm_logging.py` file contains a vulnerability where the API key masking code only masks the first 5 characters of the key.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.00767 · Published 2025-03-20 · Fixed in 1.44.12 CWE-117
Priority HIGH 72
A Denial of Service (DoS) vulnerability exists in berriai/litellm version v1.44.5.
CVSS 3.0HIGH 7.5· Network · No auth · No interaction · EPSS 0.00857 · Published 2025-03-20 · Fixed in v1.65.4-stable, 1.56.2 CWE-770
Priority HIGH 70
A vulnerability was determined in BerriAI litellm up to 1.82.2.
CVSS 4.0MEDIUM 6.9· Network · No auth · No interaction · EPSS 0.00795 · Published 2026-06-21 · No fix listed CWE-287
Priority HIGH 70
A weakness has been identified in BerriAI litellm up to 1.59.8.
CVSS 4.0MEDIUM 6.9· Network · No auth · No interaction · EPSS 0.01017 · Published 2026-06-21 · Partial fix · 1.84.0 CWE-287
Priority HIGH 68
BerriAI's litellm, in its latest version, is vulnerable to arbitrary file deletion due to improper input validation on the `/audio/transcriptions` endpoint.
CVSS 3.1HIGH 8.1· Network · Low privileges · No interaction · EPSS 0.00619 · Published 2024-06-06 · Fixed in 1.35.36 CWE-862
Priority HIGH 67
LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format.
CVSS 4.0HIGH 8.7· Network · Low privileges · No interaction · EPSS 0.38613 · Published 2026-04-06 · Partial fix · 1.83.0 CWE-863
Priority HIGH 67
An SQL Injection vulnerability exists in the berriai/litellm repository, specifically within the `/global/spend/logs` endpoint.
CVSS 3.1HIGH 7.2· Network · High privileges · No interaction · EPSS 0.00429 · Published 2024-06-06 · Fixed in 1.40.0 CWE-89
Priority HIGH 66
A Server-Side Request Forgery (SSRF) vulnerability exists in berriai/litellm version 1.38.10.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.34375 · Published 2024-09-13 · Fixed in 1.44.9, 1.44.8 CWE-918
Priority MEDIUM 62
berriai/litellm version 1.34.34 is vulnerable to improper access control in its team management functionality.
CVSS 3.1MEDIUM 6.5· Network · Low privileges · No interaction · EPSS 0.00406 · Published 2024-06-27 · Fixed in 1.40.15 CWE-862
Priority MEDIUM 58
SQL Injection vulnerability in BerriAI LiteLLM before 1.81.0 allows attackers to execute arbitrary commands via the key parameter to the "/key/block" and "/key/unblock" API endpoints.
CVSS 3.1MEDIUM 5.4· Network · No auth · User interaction · EPSS 0.00286 · Published 2025-07-03 · No fix listed CWE-89
Priority MEDIUM 57
A security vulnerability has been detected in BerriAI litellm up to 1.82.2.
CVSS 4.0MEDIUM 5.3· Network · Low privileges · No interaction · EPSS 0.00426 · Published 2026-06-21 · Fix deferred CWE-266
Priority MEDIUM 57
A weakness has been identified in BerriAI litellm up to 1.82.2.
CVSS 4.0MEDIUM 5.3· Network · Low privileges · No interaction · EPSS 0.004 · Published 2026-06-21 · Fix deferred CWE-918
Priority MEDIUM 57
A security flaw has been discovered in BerriAI litellm up to 1.82.5.
CVSS 4.0MEDIUM 5.3· Network · Low privileges · No interaction · EPSS 0.004 · Published 2026-06-21 · Fix deferred CWE-285
Priority MEDIUM 57
A vulnerability was identified in BerriAI litellm up to 1.82.2.
CVSS 4.0MEDIUM 5.3· Network · Low privileges · No interaction · EPSS 0.0057 · Published 2026-06-21 · Fix deferred CWE-613
Load more