Cost Calculator Builder PRO <= 3.2.1 - Unauthenticated Price Manipulation
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
The Cost Calculator Builder PRO plugin for WordPress is vulnerable to price manipulation in all versions up to, and including, 3.2.1. This is due to the plugin allowing the price field to be manipulated prior to processing via the 'create_cc_order' function, called from the Cost Calculator Builder plugin. This makes it possible for unauthenticated attackers to manipulate the price of orders submitted via the calculator. Note: this vulnerability was partially patched with the release of Cost Calculator Builder version 3.2.17.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| StylemixThemes | Cost Calculator Builder PRO | up to 3.2.1 | — | No fix listed | CNA |
- Cost Calculator Builder PRO VendorStylemixThemes Affected up to 3.2.1 Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:stylemixthemes:cost_calculator_builder:*:*:*:*:pro:wordpress:*:* | up to 3.1.96 | Vulnerable | StylemixThemes |
- cpe:2.3:a:stylemixthemes:cost_calculator_builder:*:*:*:*:pro:wordpress:*:* Versions up to 3.1.96 Vulnerable ·StylemixThemes
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-6010
- 2026-10-03 Alias added: GHSA-xrp5-mffj-h7gr
References
More StylemixThemes Cost Calculator Builder vulnerabilities
- TI-2024-07769 Cost Calculator Builder < 3.2.29 - Admin+ SQL Injection CVSS 3.1HIGH 7.2
- TI-2024-10096 Cost Calculator Builder < 3.2.43 - Settings update via CSRF CVSS 3.1MEDIUM 5.4
- TI-2024-28815 WordPress Cost Calculator Builder plugin <= 3.2.15 - SQL Injection vulnerability CVSS 3.1CRITICAL 9.8
- TI-2025-13473 Cost Calculator Builder <= 3.6.9 - Missing Authorization to Unauthenticated Payment Status Bypass CVSS 3.1MEDIUM 5.3
- TI-2024-05569 Cost Calculator Builder <= 3.2.12 - Authenticated (Administrator+) Stored Cross-Site Scripting CVSS 3.1MEDIUM 4.8
- TI-2024-05570 Cost Calculator Builder <= 3.2.12 - Missing Authorization to Authenticated (Subscriber+) Arbitrary Content Creation CVSS 3.1MEDIUM 4.3
Sources
- CVE-2024-6010 · CVE Program
- CVE-2024-6010 · NVD
- FIRST EPSS
- GHSA-xrp5-mffj-h7gr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences