Cost Calculator Builder <= 3.6.9 - Missing Authorization to Unauthenticated Payment Status Bypass
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-862.
Summary
The Cost Calculator Builder plugin for WordPress is vulnerable to Unauthenticated Payment Status Bypass in all versions up to, and including, 3.6.9 only when used in combination with Cost Calculator Builder PRO. This is due to the complete_payment AJAX action being registered via wp_ajax_nopriv, making it accessible to unauthenticated users, and the complete() function only verifying a nonce without checking user capabilities or order ownership. Since nonces are exposed to all visitors via window.ccb_nonces in the page source, any unauthenticated attacker can mark any order's payment status as "completed" without actual payment.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| StylemixThemes | Cost Calculator Builder | up to 3.6.9 | — | No fix listed | CNA |
- Cost Calculator Builder VendorStylemixThemes Affected up to 3.6.9 Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:stylemixthemes:cost_calculator_builder:*:*:*:*:free:wordpress:*:* | before 3.6.10 | Vulnerable | StylemixThemes |
- cpe:2.3:a:stylemixthemes:cost_calculator_builder:*:*:*:*:free:wordpress:*:* Versions before 3.6.10 Vulnerable ·StylemixThemes
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2025-14757
- 2026-10-03 Alias added: GHSA-92v6-crjv-vgf2
References
More StylemixThemes Cost Calculator Builder vulnerabilities
- TI-2024-07769 Cost Calculator Builder < 3.2.29 - Admin+ SQL Injection CVSS 3.1HIGH 7.2
- TI-2024-10096 Cost Calculator Builder < 3.2.43 - Settings update via CSRF CVSS 3.1MEDIUM 5.4
- TI-2024-28815 WordPress Cost Calculator Builder plugin <= 3.2.15 - SQL Injection vulnerability CVSS 3.1CRITICAL 9.8
- TI-2024-05568 Cost Calculator Builder PRO <= 3.2.1 - Unauthenticated Price Manipulation CVSS 3.1MEDIUM 5.3
- TI-2024-05569 Cost Calculator Builder <= 3.2.12 - Authenticated (Administrator+) Stored Cross-Site Scripting CVSS 3.1MEDIUM 4.8
- TI-2024-05570 Cost Calculator Builder <= 3.2.12 - Missing Authorization to Authenticated (Subscriber+) Arbitrary Content Creation CVSS 3.1MEDIUM 4.3
Sources
- CVE-2025-14757 · CVE Program
- CVE-2025-14757 · NVD
- FIRST EPSS
- GHSA-92v6-crjv-vgf2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences