Improper certificate validation in Canonical LXD
Priority MEDIUM 51CWE-295Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Spoofing
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-295.
Summary
Mark Laing discovered that LXD's PKI mode, until version 5.21.2, could be bypassed if the client's certificate was present in the trust store.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00159 5th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed LXD (Canonical Ltd.): 4.0.10, 5.0.4, 5.21.2 +1github.com/canonical/lxd (Go): 0.0.0-20240708073652-5a492a3f0036
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Canonical | LXD | 4.0 to before 4.0.10; 4.0 to before 5.0.4; 4.0 to before 5.21.2; 4.0 to before 6.1 | 4.0.10, 5.0.4, 5.21.2, 6.1 | Patch available | CNA |
| — | github.com/canonical/lxd (Go) | before 0.0.0-20240708073652-5a492a3f0036 | 0.0.0-20240708073652-5a492a3f0036 | Patch available | GHSA-4c49-9fpc-hc3v |
- LXD VendorCanonical Affected 4.0 to before 4.0.10; 4.0 to before 5.0.4; 4.0 to before 5.21.2; 4.0 to before 6.1 Fixed in 4.0.10, 5.0.4, 5.21.2, 6.1 Patch available CNA
- github.com/canonical/lxd (Go) Vendor— Affected before 0.0.0-20240708073652-5a492a3f0036 Fixed in 0.0.0-20240708073652-5a492a3f0036 Patch available GHSA-4c49-9fpc-hc3v
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:canonical:lxd:*:*:*:*:*:*:*:* | 4.0.0 to before 4.0.10; 5.0.0 to before 5.0.4; 5.1 to before 5.21.2 | Vulnerable | Canonical |
- cpe:2.3:a:canonical:lxd:*:*:*:*:*:*:*:* Versions 4.0.0 to before 4.0.10; 5.0.0 to before 5.0.4; 5.1 to before 5.21.2 Vulnerable ·Canonical
Remediation
- Fix · CNA LXD (Canonical Ltd.) Fixed in 4.0.10, 5.0.4, 5.21.2, 6.1
- Fix · GHSA-4c49-9fpc-hc3v github.com/canonical/lxd (Go) Fixed in 0.0.0-20240708073652-5a492a3f0036 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-6156
- 2026-10-03 Alias added: GHSA-4c49-9fpc-hc3v
References
Advisory 2
More Canonical Lxd vulnerabilities
- TI-2026-22659 Authenticated RCE via unsanitized compression_algorithm CVSS 4.0CRITICAL 9.4
- TI-2026-47475 Path traversal via unvalidated instance name in backup tarball restore enables root file write / RCE CVSS 3.1CRITICAL 9.9
- TI-2026-45146 Cross-project instance move bypasses all project restrictions allowing host command execution CVSS 3.1CRITICAL 9.9
- TI-2026-45143 Cross-project instance copy bypasses target project restrictions via TOCTOU in config merge CVSS 3.1CRITICAL 9.9
- TI-2026-45142 Project restriction bypass via instance migration config override CVSS 3.1CRITICAL 9.9
- TI-2026-45140 Root RCE via image backup.yaml symlink CVSS 3.1CRITICAL 9.9
Sources
- CVE-2024-6156 · CVE Program
- CVE-2024-6156 · NVD
- FIRST EPSS
- GHSA-4c49-9fpc-hc3v · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences