Read the docs
TI-2024-05790 Aliases CVE-2024-6243GHSA-4r8x-26vf-3hx6

HTML Forms < 1.3.33 - Admin+ Stored XSS

Priority MEDIUM 60CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · Low
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.

Summary

The HTML Forms WordPress plugin before 1.3.33 does not sanitize and escape the form message inputs, allowing high-privilege users, such as administrators, to perform Stored Cross-Site Scripting (XSS) attacks even when the unfiltered_html capability is disabled.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00353 29th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed HTML Forms (Unknown): 1.3.33

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownHTML Forms before 1.3.331.3.33Patch availableCNA
  • HTML Forms VendorUnknown Affected before 1.3.33 Fixed in 1.3.33 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:linksoftwarellc:html_forms:*:*:*:*:*:wordpress:*:*before 1.3.33VulnerableLinksoftwarellc
  • cpe:2.3:a:linksoftwarellc:html_forms:*:*:*:*:*:wordpress:*:* Versions before 1.3.33 Vulnerable ·Linksoftwarellc

Remediation

  • Fix · CNA HTML Forms (Unknown) Fixed in 1.3.33

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-6243
  2. 2026-10-03 Alias added: GHSA-4r8x-26vf-3hx6

References

  • TI-2022-03391 HTML Forms < 1.3.25 - Admin+ SQLi CVSS 3.1HIGH 7.2
  • TI-2024-05952 HTML Forms – Simple WordPress Forms Plugin < 1.3.34 - Bulk Delete via CSRF CVSS 3.1MEDIUM 6.5
  • TI-2025-28988 WordPress HTML Forms plugin <= 1.5.2 - Cross Site Scripting (XSS) Vulnerability CVSS 3.1MEDIUM 6.5
  • TI-2023-27741 WordPress HTML Forms Plugin <= 1.3.28 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 5.9

Sources