HTML Forms – Simple WordPress Forms Plugin < 1.3.34 - Bulk Delete via CSRF
Priority MEDIUM 62CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-352.
Summary
The HTML Forms WordPress plugin before 1.3.34 does not have CSRF checks in some places, which could allow attackers to make logged in users perform unwanted actions via CSRF attacks
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00268 19th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed HTML Forms (Unknown): 1.3.34
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | HTML Forms | before 1.3.34 | 1.3.34 | Patch available | CNA |
- HTML Forms VendorUnknown Affected before 1.3.34 Fixed in 1.3.34 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:linksoftwarellc:html_forms:*:*:*:*:*:wordpress:*:* | before 1.3.34 | Vulnerable | Linksoftwarellc |
- cpe:2.3:a:linksoftwarellc:html_forms:*:*:*:*:*:wordpress:*:* Versions before 1.3.34 Vulnerable ·Linksoftwarellc
Remediation
- Fix · CNA HTML Forms (Unknown) Fixed in 1.3.34
Timeline
- 2026-10-02 Threatist record created from CVE-2024-6412
- 2026-10-03 Alias added: GHSA-jmmr-w66h-7p5r
References
More Linksoftwarellc Html Forms vulnerabilities
- TI-2022-03391 HTML Forms < 1.3.25 - Admin+ SQLi CVSS 3.1HIGH 7.2
- TI-2024-05790 HTML Forms < 1.3.33 - Admin+ Stored XSS CVSS 3.1MEDIUM 5.9
- TI-2025-28988 WordPress HTML Forms plugin <= 1.5.2 - Cross Site Scripting (XSS) Vulnerability CVSS 3.1MEDIUM 6.5
- TI-2023-27741 WordPress HTML Forms Plugin <= 1.3.28 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 5.9
Sources
- CVE-2024-6412 · CVE Program
- CVE-2024-6412 · NVD
- FIRST EPSS
- GHSA-jmmr-w66h-7p5r · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences