Relevanssi <= 4.22.2 (Free) and <= 2.25.1 (Premium) - Unauthenticated Information Exposure
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-200.
Summary
The Relevanssi – A Better Search plugin for WordPress is vulnerable to Information Exposure in all versions up to, and including, 4.22.2 (Free) and 2.25.1 (Premium) via the relevanssi_do_query() due to insufficient limitations on the posts that are returned when searching. This makes it possible for unauthenticated attackers to extract potentially sensitive information from password protected posts.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-7630
- 2026-10-03 Alias added: GHSA-44xh-w98h-vq6q
References
More comesio Relevanssi vulnerabilities
- TI-2023-06585 Relevanssi (Free < 4.22.0, Premium < 2.25.0) - Unauthenticated Private/Draft Post Disclosure CVSS 3.1MEDIUM 5.3
- TI-2024-01287 Missing authorization in comesio Relevanssi Premium CVSS 3.1MEDIUM 5.3
- TI-2024-08374 Relevanssi < 4.23.1 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.4
- TI-2024-03012 Relevanssi – A Better Search <= 4.22.1 - Unauthenticated Second Order CSV Injection CVSS 3.1CRITICAL 9.8
- TI-2024-03011 Relevanssi – A Better Search <= 4.22.1 - Missing Authorization to Unauthenticated Count Option Update CVSS 3.1HIGH 8.2
- TI-2016-08987 The Relevanssi Premium plugin before 1.14.6.1 for WordPress has SQL injection with resultant unsafe unserialization. CVSS 3.1HIGH 8.8
Sources
- CVE-2024-7630 · CVE Program
- CVE-2024-7630 · NVD
- FIRST EPSS
- GHSA-44xh-w98h-vq6q · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences