Cross-site scripting in wpWax Logo Showcase Ultimate – Logo Carousel, Logo Slider & Logo…
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
The Logo Showcase Ultimate – Logo Carousel, Logo Slider & Logo Grid plugin for WordPress is vulnerable to Stored Cross-Site Scripting via SVG File uploads in all versions up to, and including, 1.4.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses the SVG file.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-8046
- 2026-10-03 Alias added: GHSA-x586-j2rp-5xgv
References
Other 5
- https://www.wordfence.com/threat-intel/vulnerabilities/id/89525af0-105a-4d7d-93d1-af724a837e7a?source=cve
- https://plugins.trac.wordpress.org/browser/logo-showcase-ultimate/tags/1.4.1/lcg_adl_main.php#L236
- https://wordpress.org/plugins/logo-showcase-ultimate/#developers
- https://plugins.trac.wordpress.org/changeset/3141393/#file3
- https://plugins.trac.wordpress.org/changeset/3141393/
More wpWax vulnerabilities
- TI-2022-03630 Directorist < 7.4.4 - Subscriber+ Sensitive Information Disclosure CVSS 3.1MEDIUM 6.5
- TI-2022-03605 Directorist < 7.4.2.2 - Subscriber+ Arbitrary User Password Update via IDOR CVSS 3.1MEDIUM 6.5
- TI-2026-42481 WordPress Directorist plugin <= 8.8.2 - PHP Object Injection vulnerability CVSS 3.1CRITICAL 9.8
- TI-2025-23723 WordPress HelpGent plugin <= 2.2.5 - PHP Object Injection vulnerability CVSS 3.1CRITICAL 9.8
- TI-2024-01866 Deserialization of untrusted data in wpWax Post Grid, Slider & Carousel Ultimate – with… CVSS 3.1HIGH 8.8
- TI-2026-02713 FormGent <= 1.9.2- Missing Authorization to Unauthenticated Arbitrary File Deletion via 'file_token' Parameter CVSS 3.1CRITICAL 9.1
Sources
- CVE-2024-8046 · CVE Program
- CVE-2024-8046 · NVD
- FIRST EPSS
- GHSA-x586-j2rp-5xgv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences