The Ultimate WordPress Toolkit – WP Extended <= 3.0.8 - Missing Authorization to Admin Username Change
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · Low
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-862.
Summary
The The Ultimate WordPress Toolkit – WP Extended plugin for WordPress is vulnerable to unauthorized modification of user names due to a missing capability check on the wpext_change_admin_name() function in all versions up to, and including, 3.0.8. This makes it possible for authenticated attackers, with Subscriber-level access and above, to change an admin's username to a username of their liking as long as the default 'admin' was used.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| wpextended | The Ultimate WordPress Toolkit – WP Extended | up to 3.0.8 | — | No fix listed | CNA |
- The Ultimate WordPress Toolkit – WP Extended Vendorwpextended Affected up to 3.0.8 Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:wpextended:wp_extended:*:*:*:*:*:wordpress:*:* | before 3.0.9 | Vulnerable | wpextended |
- cpe:2.3:a:wpextended:wp_extended:*:*:*:*:*:wordpress:*:* Versions before 3.0.9 Vulnerable ·wpextended
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-8121
- 2026-10-03 Alias added: GHSA-9299-82cr-w458
References
More wpextended Wp Extended vulnerabilities
- TI-2024-07515 Path traversal in wpextended The Ultimate WordPress Toolkit – WP Extended CVSS 3.1HIGH 8.8
- TI-2024-07513 The Ultimate WordPress Toolkit – WP Extended <= 3.0.8 - Authenticated (Subscriber+) Arbitrary Options Update CVSS 3.1HIGH 8.8
- TI-2024-24774 WordPress WP Extended plugin <= 2.4.7 - Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
- TI-2024-11055 Missing authorization in wpextended The Ultimate WordPress Toolkit – WP Extended CVSS 3.1HIGH 7.4
- TI-2024-12595 Missing authorization in wpextended The Ultimate WordPress Toolkit – WP Extended CVSS 3.1MEDIUM 5.3
- TI-2024-07517 The Ultimate WordPress Toolkit – WP Extended <= 3.0.8 - Authenticated (Subscriber+) Sensitive Information Exposure CVSS 3.1MEDIUM 6.5
Sources
- CVE-2024-8121 · CVE Program
- CVE-2024-8121 · NVD
- FIRST EPSS
- GHSA-9299-82cr-w458 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences