Read the docs
TI-2024-07660 Aliases CVE-2024-8263GHSA-q586-q77x-838f

Improper privilege management in GitHub Enterprise Server

Priority LOW 28CWE-269Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
None
Attack complexity
Low
Attack requirements
None
Impact type
Privilege escalation
Confidentiality · integrity · availability
None · Low · None
Fix status
No fix listed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-269.

Summary

An improper privilege management vulnerability allowed arbitrary workflows to be committed using an improperly scoped PAT through the use of nested tags. This vulnerability affected all versions of GitHub Enterprise Server and was fixed in version 3.10.17, 3.11.15, 3.12.9, 3.13.4, and 3.14.1. This vulnerability was reported via the GitHub Bug Bounty program.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00449 39th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
GitHubGitHub Enterprise Server3.14 – 3.14.0; 3.13.0 – 3.13.3; 3.12.0 – 3.12.8; 3.11.0 – 3.11.14; 3.10.0 – 3.10.16—No fix listedCNA
  • GitHub Enterprise Server VendorGitHub Affected 3.14 – 3.14.0; 3.13.0 – 3.13.3; 3.12.0 – 3.12.8; 3.11.0 – 3.11.14; 3.10.0 – 3.10.16 Fixed in — No fix listed CNA

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:github:enterprise_server:*:*:*:*:*:*:*:*3.10.0 to before 3.10.17; 3.11.0 to before 3.11.15; 3.12.0 to before 3.12.9; 3.13.0 to before 3.13.4VulnerableGitHub
cpe:2.3:a:github:enterprise_server:3.14.0:*:*:*:*:*:*:*3.14.0VulnerableGitHub
  • cpe:2.3:a:github:enterprise_server:*:*:*:*:*:*:*:* Versions 3.10.0 to before 3.10.17; 3.11.0 to before 3.11.15; 3.12.0 to before 3.12.9; 3.13.0 to before 3.13.4 Vulnerable ·GitHub
  • cpe:2.3:a:github:enterprise_server:3.14.0:*:*:*:*:*:*:* Versions 3.14.0 Vulnerable ·GitHub

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-8263
  2. 2026-10-03 Alias added: GHSA-q586-q77x-838f

References

  • TI-2024-04632 An authentication bypass vulnerability was present in the GitHub Enterprise Server (GHES)… CVSS 4.0CRITICAL 10.0
  • TI-2024-00181 Unsafe Reflection in Github Enterprise Server leading to Command Injection CVSS 3.1CRITICAL 9.8
  • TI-2024-00466 Privilege Escalation by Code Injection in the Management Console in GitHub Enterprise Server CVSS 3.1HIGH 8.8
  • TI-2026-03340 Remote code execution via git push option injection in GitHub Enterprise Server CVSS 4.0HIGH 8.7
  • TI-2024-08804 Improper signature verification in GitHub Enterprise Server CVSS 4.0CRITICAL 9.5
  • TI-2026-08177 Server-side request forgery in GitHub Enterprise Server CVSS 4.0CRITICAL 9.2
See all 125 →

Sources