Quiz Maker <= 6.5.9.8 - Admin+ Stored XSS
Priority MEDIUM 55CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Quiz Maker WordPress plugin before 6.5.9.9 does not sanitize and escape some of its settings, which could allow high-privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00326 25th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Quiz Maker (Unknown): 6.5.9.9
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Quiz Maker | before 6.5.9.9 | 6.5.9.9 | Patch available | CNA |
- Quiz Maker VendorUnknown Affected before 6.5.9.9 Fixed in 6.5.9.9 Patch available CNA
Remediation
- Fix · CNA Quiz Maker (Unknown) Fixed in 6.5.9.9
Timeline
- 2026-10-02 Threatist record created from CVE-2024-8617
- 2026-10-03 Alias added: GHSA-9mpf-r669-m5wq
References
More Ays Pro Quiz Maker vulnerabilities
- TI-2024-09849 Quiz Maker Business, Developer, and Agency <= (Multiple Versions) - Unauthenticated SQL Injection via id CVSS 3.1HIGH 7.5
- TI-2023-05660 Quiz Maker < 6.4.9.5 - Unauthenticated Email Address Disclosure CVSS 3.1MEDIUM 5.3
- TI-2024-05586 Quiz Maker <= 6.5.8.3 - Unauthenticated SQL Injection via 'ays_questions' Parameter CVSS 3.1CRITICAL 9.8
- TI-2023-02403 Quiz Maker < 6.4.2.7 - Reflected XSS CVSS 3.1MEDIUM 6.1
- TI-2025-09218 Quiz Maker <= 6.7.0.56 - Unauthenticated SQL Injection CVSS 3.1HIGH 7.5
- TI-2025-22044 WordPress Quiz Maker plugin <= 6.6.8.7 - SQL Injection vulnerability CVSS 3.1CRITICAL 9.8
Sources
- CVE-2024-8617 · CVE Program
- CVE-2024-8617 · NVD
- FIRST EPSS
- GHSA-9mpf-r669-m5wq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences