Privilege Escalation in lunary-ai/lunary
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-863.
Summary
In lunary-ai/lunary before version 1.4.30, a privilege escalation vulnerability exists where admins can invite new members with billing permissions, thereby gaining unauthorized access to billing resources. This issue arises because the user creation endpoint does not restrict admins from inviting users with billing roles. As a result, admins can circumvent the intended access control, posing a risk to the organization's financial resources.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA lunary-ai/lunary (lunary-ai) Fixed in 1.4.30
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
lunary-ai/lunary 1.4.30
3 records Highest priority Priority HIGH 1 HIGH, 2 MEDIUM
Other records, highest priority first
- TI-2024-08445 Improper Authorization in lunary-ai/lunaryPriority HIGH 82
- TI-2024-08446 Improper Authorization in lunary-ai/lunaryPriority MEDIUM 64
Timeline
- 2026-10-02 Threatist record created from CVE-2024-9098
- 2026-10-03 Alias added: GHSA-fxpx-7wrq-8ggp
References
More lunary-ai Lunary vulnerabilities
- TI-2024-08445 Improper Authorization in lunary-ai/lunary CVSS 3.1CRITICAL 9.8
- TI-2024-06910 SQL Injection in lunary-ai/lunary CVSS 3.1CRITICAL 9.8
- TI-2024-03859 Incorrect Authorization in lunary-ai/lunary CVSS 3.1CRITICAL 9.8
- TI-2024-06928 Improper Access Control in lunary-ai/lunary CVSS 3.1CRITICAL 9.1
- TI-2024-03267 Exposure of Sensitive Information in lunary-ai/lunary CVSS 3.1CRITICAL 9.1
- TI-2024-03266 Exposure of Sensitive Information in lunary-ai/lunary CVSS 3.1CRITICAL 9.1
Sources
- CVE-2024-9098 · CVE Program
- CVE-2024-9098 · NVD
- FIRST EPSS
- GHSA-fxpx-7wrq-8ggp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences